summaryrefslogtreecommitdiff
path: root/dev-ruby/slop
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-30 17:36:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-30 17:36:28 +0100
commit7014a5a3ea0feffab9701fdd6b64cc7667a985af (patch)
treef2cbbaa8bb9209cd15208721103228336149b799 /dev-ruby/slop
parent7a86906b67693cc65671d3e1476835d3a7e13092 (diff)
gentoo resync : 30.06.2019
Diffstat (limited to 'dev-ruby/slop')
-rw-r--r--dev-ruby/slop/Manifest2
-rw-r--r--dev-ruby/slop/slop-4.7.0.ebuild26
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-ruby/slop/Manifest b/dev-ruby/slop/Manifest
index 9b2a504dbbcb..6429496a92e5 100644
--- a/dev-ruby/slop/Manifest
+++ b/dev-ruby/slop/Manifest
@@ -1,3 +1,5 @@
DIST slop-4.6.2.tgz 15750 BLAKE2B a31c8ec895e534be7fe77eb09909c2210d298c1a89099080af816b9e06a5ee2358aef223b1ce0669f9d40cc91c04ce55e8ebb6d506a4bec35fb1fd9b93c0017d SHA512 352d7e5bbbe9ae4c324d1561f953fe28c1c99078bdef27f1be45453e60b34e0191e94d8952ec0a8cee7d689c6ba910616c9515747e81a8378fa825cb2139bfc7
+DIST slop-4.7.0.tgz 16367 BLAKE2B ad128b803876184cddaca5fdc4c8a1c2d20a0deab46cfcc9521cec88dbc777ee849a8bda8b0257281fdcb614a1e710e25b683f9a5f7d97d34ad78e3a1479a88f SHA512 3cbf1c7e2a7f2baf01e533b10f29cb52060dab2d03f69ba345b63cc0aa9d4cdebf1d18eff26177bfbac11bf55fd1167605dcc86d030fed0568fa132de33d1f37
EBUILD slop-4.6.2.ebuild 635 BLAKE2B b1b4573bf58078650383164ce5823f3db2516ccd0883464f1704f055729b6c8efcd15d72a7c94f661f492fcc65380ab320adfd9a1a3e47628439bd706b21adb9 SHA512 29c726c01afd53335a23f3ddead72cf1243a52ce23597c1176d1ab9d6a9d3a679c6398cdad837cd82a90736f898e3949ab71cd0159ab1715e2db789fdf0891de
+EBUILD slop-4.7.0.ebuild 628 BLAKE2B 7a8be65483e62b83de733de381e14f8deaa685153533c7bee1e873e4f4df8330b4666db9d276105b4f8e44fc68ff45eaa4c85568024dc1a34ac1069d1bda3f39 SHA512 f0251e32680d22f7cbd5745d371f874cef4ac7ce14a1730f6062e339e1bb632d5185b39f145902d27e740a482026598d7f6c12c6bf176150d63e36b05d9e4a8f
MISC metadata.xml 337 BLAKE2B 257bf07d00a3f336c737c4135fae690b12a7b383de865d09fca95667efdfc4d66adcb55343b064c1fefa190f1f7c21c7b3f18ecde8d73e9d7632209ee8adc720 SHA512 2036c518a80c08e41ddec04f397959241a28fdbec0071c98120bbe2fade6e69ef67b1aa46191099520dced091d5aa0d16ae1484d831061c0681315cb0fa3b35a
diff --git a/dev-ruby/slop/slop-4.7.0.ebuild b/dev-ruby/slop/slop-4.7.0.ebuild
new file mode 100644
index 000000000000..9ca73f9366d6
--- /dev/null
+++ b/dev-ruby/slop/slop-4.7.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A simple option parser with an easy to remember syntax and friendly API"
+HOMEPAGE="https://github.com/injekt/slop"
+SRC_URI="https://github.com/injekt/${PN}/archive/v${PV}.tar.gz -> ${P}.tgz"
+
+LICENSE="MIT"
+SLOT="4"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/minitest )"
+
+all_ruby_prepare() {
+ sed -i -e '/git ls-files/d' slop.gemspec || die
+}