summaryrefslogtreecommitdiff
path: root/dev-ruby/six
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/six
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/six')
-rw-r--r--dev-ruby/six/Manifest3
-rw-r--r--dev-ruby/six/metadata.xml11
-rw-r--r--dev-ruby/six/six-0.2.0.ebuild24
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-ruby/six/Manifest b/dev-ruby/six/Manifest
new file mode 100644
index 000000000000..7663b5891018
--- /dev/null
+++ b/dev-ruby/six/Manifest
@@ -0,0 +1,3 @@
+DIST six-0.2.0.tar.gz 6747 BLAKE2B acf034ac527b3e5379a55ad95bacdf18d544577cad9e7f7ea322e6b05d2b1557f5712915ec79d51e48e5d246661f384207a5eae07775a85e27548fb9af99e6fb SHA512 8c3bfbe2b07b5682b696800a9235ebf542c7d292f69728aa9c9707f92fa042fe7bfee6a0b28808dab86f8ec80fec5ba993be5e42f4a098d8cfccbc7611fa2016
+EBUILD six-0.2.0.ebuild 588 BLAKE2B b7bc09b2904d94d4247a2d64b4dc71a3888995aa9a0b2e77e13a965d465aad2c2bbb9a5d70a7535ff8bc19e14f4d11fda5d9237df2e33f862c5b20dcac86b83d SHA512 af1661d0f3120130010ff1e188c1f0fab911bdc8d00dbffb4597c1e39a6faa6fb04424d477e6d504d5a0244230140896e54bb56fd2f88b8b5820d64344c57a4e
+MISC metadata.xml 335 BLAKE2B e1bafe2e453249abe6095958abfad021b1c49785b441431663154e63d4e69cc86227c2d157eb161eb53b8e1a553459ba9e0f0f651b6092cccc8c006dae6bc21e SHA512 7321ca2e3338f779ed480d672160c7903fee2c989dc88a7f8df76bd8a3c8aef7569bf6805ecdb62328df70650634fb6e6392f73929bb281e148f7d8fb330440b
diff --git a/dev-ruby/six/metadata.xml b/dev-ruby/six/metadata.xml
new file mode 100644
index 000000000000..8f5dc5aab86f
--- /dev/null
+++ b/dev-ruby/six/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">randx/six</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/six/six-0.2.0.ebuild b/dev-ruby/six/six-0.2.0.ebuild
new file mode 100644
index 000000000000..beb43f942e72
--- /dev/null
+++ b/dev-ruby/six/six-0.2.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_RECIPE_DOC=""
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG README.markdown"
+
+inherit ruby-fakegem
+
+DESCRIPTION="An ultra lite authorization library"
+HOMEPAGE="https://github.com/randx/six"
+SRC_URI="https://github.com/randx/six/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/[Bb]undler/d' spec/spec_helper.rb || die "sed failed"
+}