summaryrefslogtreecommitdiff
path: root/dev-ruby/singleton
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-10-29 03:04:53 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-10-29 03:04:53 +0000
commitbd35a61d88b111f25f4b10126e0d4755545fc7a5 (patch)
tree656ac661ed7b28ad66ba778b74bc5fe4e2b86b10 /dev-ruby/singleton
parent5d4291ee2ba8b85e8515b5f47b814a5c872eed04 (diff)
gentoo auto-resync : 29:10:2024 - 03:04:53
Diffstat (limited to 'dev-ruby/singleton')
-rw-r--r--dev-ruby/singleton/Manifest2
-rw-r--r--dev-ruby/singleton/singleton-0.1.1.ebuild31
2 files changed, 0 insertions, 33 deletions
diff --git a/dev-ruby/singleton/Manifest b/dev-ruby/singleton/Manifest
index 2f5fe9867fcd..3cefa2704c06 100644
--- a/dev-ruby/singleton/Manifest
+++ b/dev-ruby/singleton/Manifest
@@ -1,5 +1,3 @@
-DIST singleton-0.1.1.tar.gz 4975 BLAKE2B 3957c7d622aaad6a71b5675ad950b2a4622ec520b59075df25a966609e54c2f47581ba35c5a004c67a1a36f50de13dacadbc96ee1fd113790e6793e97131787c SHA512 a0817b42e8b056488b999eca8de09d75efe79e5624f4817289164d90051c92279dc9f8a087e69df89bec913127c460b8b6586fde17b73e08d4ec5b6da4dec18d
DIST singleton-0.2.0.tar.gz 5179 BLAKE2B 8d0ed2fb38ff8fc8bd5da3969c4e0dcc3c5556b69dfa7faceb9d02d80b69d902418d54b8a313188927938adb1431fa593aaea0249109c34b809c6d3a35ba08b4 SHA512 e6c827f277754fc20722afbf20c67b22fc44095337777e69afa0eff8c88390be86741b244ee35124fc2684fbe048d439dfe96499617ec672275fdd7e64d36e43
-EBUILD singleton-0.1.1.ebuild 936 BLAKE2B ad24be45cc046bb5db5b5872e136ae2c4517b35bbaac28b604b9d10d19c886814b66cda37aad9346089a9fac1af96957f45d899d25cdf7a15ced08085a5d4cc1 SHA512 3e865d5020bd6748ac13efbe391cd098ee41731bf4cf7f1bc6fae38e2c8043449ce412289c2b2ad2c82a2583110e471aec3ed9f394cefbd0e2c15ddcdb83325e
EBUILD singleton-0.2.0.ebuild 929 BLAKE2B 330af33f0e0108ec682a783c9c34ca7de3debc89fdc4daa45e15d281aff605d365d0748ad32cd5fa6b228a4ae7b3ecbab3d2a31e00ea46e07d0c5a46362bf1df SHA512 272b6bac9b07ac55b11a741c506916419f7fb85d5d184758c6f80f6f4127fcee2cca232b5f7e41d37f08185a6971e02198fd631547cf370d439c725ed80f737e
MISC metadata.xml 341 BLAKE2B e45d6753c4c9675cbb363078ea6614bcaccab98915bd3dcaaf7215c8ad608eba313c81f3bb90ce05e4b19981c408c44acfb09f1856652bd09bc459fa1c977d9e SHA512 572ab9227b892081aa5b43a60b4cdd50a4ab0953e7e820403836d7c1f61ac011df9506ef3bc036aa32fbdd8752f0693478d02d02a938558b2a46650aa2c1a0f3
diff --git a/dev-ruby/singleton/singleton-0.1.1.ebuild b/dev-ruby/singleton/singleton-0.1.1.ebuild
deleted file mode 100644
index 38bed07c0307..000000000000
--- a/dev-ruby/singleton/singleton-0.1.1.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-USE_RUBY="ruby27 ruby30 ruby31 ruby32"
-
-RUBY_FAKEGEM_BINWRAP=""
-RUBY_FAKEGEM_EXTRADOC="README.md"
-RUBY_FAKEGEM_GEMSPEC="singleton.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="The Singleton module implements the Singleton pattern"
-HOMEPAGE="https://github.com/ruby/singleton"
-SRC_URI="https://github.com/ruby/singleton/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
-IUSE=""
-
-all_ruby_prepare() {
- sed -e 's/__dir__/"."/' \
- -e 's/__FILE__/"'${RUBY_FAKEGEM_GEMSPEC}'"/' \
- -e 's/git ls-files -z/find * -print0/' \
- -i ${RUBY_FAKEGEM_GEMSPEC} || die
-}
-
-each_ruby_test() {
- ${RUBY} -Ilib:.:test:test/lib -e 'Dir["test/**/test_*.rb"].each{|f| require f}' || die
-}