summaryrefslogtreecommitdiff
path: root/dev-ruby/singleton
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-ruby/singleton
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-ruby/singleton')
-rw-r--r--dev-ruby/singleton/Manifest3
-rw-r--r--dev-ruby/singleton/metadata.xml11
-rw-r--r--dev-ruby/singleton/singleton-0.1.1.ebuild31
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-ruby/singleton/Manifest b/dev-ruby/singleton/Manifest
new file mode 100644
index 000000000000..33ab2501790c
--- /dev/null
+++ b/dev-ruby/singleton/Manifest
@@ -0,0 +1,3 @@
+DIST singleton-0.1.1.tar.gz 4975 BLAKE2B 3957c7d622aaad6a71b5675ad950b2a4622ec520b59075df25a966609e54c2f47581ba35c5a004c67a1a36f50de13dacadbc96ee1fd113790e6793e97131787c SHA512 a0817b42e8b056488b999eca8de09d75efe79e5624f4817289164d90051c92279dc9f8a087e69df89bec913127c460b8b6586fde17b73e08d4ec5b6da4dec18d
+EBUILD singleton-0.1.1.ebuild 981 BLAKE2B ba6bc7a870fc9da125a2ee258cb8e4ae5287ed4248e0528ec8af823ea2da7901164de21b594536a2898776e1779f898714c089eed901a38f4c02548820bdd748 SHA512 71e13cfaaede6f3d8d4c0e346104fefbeb903720a14adc5bc5af7e042d155eee3829d45ef3b7ad38aa845200492bfd6bb4ed2f7e0e51e7861da6b1115bb030ed
+MISC metadata.xml 341 BLAKE2B e45d6753c4c9675cbb363078ea6614bcaccab98915bd3dcaaf7215c8ad608eba313c81f3bb90ce05e4b19981c408c44acfb09f1856652bd09bc459fa1c977d9e SHA512 572ab9227b892081aa5b43a60b4cdd50a4ab0953e7e820403836d7c1f61ac011df9506ef3bc036aa32fbdd8752f0693478d02d02a938558b2a46650aa2c1a0f3
diff --git a/dev-ruby/singleton/metadata.xml b/dev-ruby/singleton/metadata.xml
new file mode 100644
index 000000000000..2c38c2ef94ba
--- /dev/null
+++ b/dev-ruby/singleton/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ruby/singleton</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/singleton/singleton-0.1.1.ebuild b/dev-ruby/singleton/singleton-0.1.1.ebuild
new file mode 100644
index 000000000000..cabbd7428cfa
--- /dev/null
+++ b/dev-ruby/singleton/singleton-0.1.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_GEMSPEC="singleton.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="The Singleton module implements the Singleton pattern"
+HOMEPAGE="https://github.com/ruby/singleton"
+SRC_URI="https://github.com/ruby/singleton/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -e 's/__dir__/"."/' \
+ -e 's/__FILE__/"'${RUBY_FAKEGEM_GEMSPEC}'"/' \
+ -e 's/git ls-files -z/find * -print0/' \
+ -i ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:.:test:test/lib -e 'Dir["test/**/test_*.rb"].each{|f| require f}' || die
+}