summaryrefslogtreecommitdiff
path: root/dev-ruby/simplecov/simplecov-0.22.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-22 12:42:36 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-22 12:42:36 +0000
commit0db63353439ccde38447ea44cc8f16793d443f88 (patch)
treec98bf4ac6647c7cb6794a5e71d445d5c0f9f27ff /dev-ruby/simplecov/simplecov-0.22.0.ebuild
parentaaeed2da8906f11cba80355688015d74b01cc604 (diff)
gentoo auto-resync : 22:03:2023 - 12:42:36
Diffstat (limited to 'dev-ruby/simplecov/simplecov-0.22.0.ebuild')
-rw-r--r--dev-ruby/simplecov/simplecov-0.22.0.ebuild13
1 files changed, 8 insertions, 5 deletions
diff --git a/dev-ruby/simplecov/simplecov-0.22.0.ebuild b/dev-ruby/simplecov/simplecov-0.22.0.ebuild
index 1f2ded59ddcd..22e7cc4d0130 100644
--- a/dev-ruby/simplecov/simplecov-0.22.0.ebuild
+++ b/dev-ruby/simplecov/simplecov-0.22.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-USE_RUBY="ruby27 ruby30 ruby31"
+USE_RUBY="ruby27 ruby30 ruby31 ruby32"
RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
@@ -36,6 +36,10 @@ ruby_add_bdepend "test? (
# There are also cucumber tests that require poltergeist and unpackaged phantomjs gem.
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.22.0-ruby32-gentoo.patch
+)
+
all_ruby_prepare() {
# Avoid test depending on spawning ruby and having timing issues
sed -i -e '/blocks other processes/askip "gentoo"' spec/result_merger_spec.rb || die
@@ -48,7 +52,6 @@ all_ruby_prepare() {
}
each_ruby_test() {
- RSPEC_VERSION=3 ruby-ng_rspec spec/*spec.rb || die
-
- #${RUBY} -S cucumber features || die
+ sed -i -e "s:@GENTOO_RUBY@:${RUBY}:" spec/coverage_for_eval_spec.rb || die
+ RSPEC_VERSION=3 ruby-ng_rspec spec/ || die
}