summaryrefslogtreecommitdiff
path: root/dev-ruby/simplecov/simplecov-0.14.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
commitde49812990871e1705b64051c35161d5e6400269 (patch)
tree5e1e8fcb0ff4579dbd22a1bfee28a6b97dc8aaeb /dev-ruby/simplecov/simplecov-0.14.1.ebuild
parent536c3711867ec947c1738f2c4b96f22e4863322d (diff)
gentoo resync : 24.12.2018
Diffstat (limited to 'dev-ruby/simplecov/simplecov-0.14.1.ebuild')
-rw-r--r--dev-ruby/simplecov/simplecov-0.14.1.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/dev-ruby/simplecov/simplecov-0.14.1.ebuild b/dev-ruby/simplecov/simplecov-0.14.1.ebuild
deleted file mode 100644
index f654c61a46c8..000000000000
--- a/dev-ruby/simplecov/simplecov-0.14.1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-USE_RUBY="ruby22 ruby23 ruby24"
-
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
-
-RUBY_FAKEGEM_DOCDIR="doc"
-RUBY_FAKEGEM_TASK_DOC=""
-
-inherit ruby-fakegem
-
-DESCRIPTION="Code coverage with a configuration library and merging across test suites"
-HOMEPAGE="https://www.ruby-toolbox.com/projects/simplecov https://github.com/colszowka/simplecov"
-LICENSE="MIT"
-
-KEYWORDS="~amd64"
-SLOT="0.8"
-IUSE="doc"
-
-ruby_add_rdepend ">=dev-ruby/json-1.8:0 <dev-ruby/json-3:0
- dev-ruby/simplecov-html:0.10
- =dev-ruby/docile-1.1*"
-
-ruby_add_bdepend "test? (
- dev-ruby/rspec:3
- dev-ruby/test-unit:2
-)"
-
-# There are also cucumber tests that require poltergeist and unpackaged phantomjs gem.
-
-all_ruby_prepare() {
- sed -i -e '/[Bb]undler/ s:^:#:' spec/helper.rb features/support/env.rb || die
-}
-
-each_ruby_test() {
- RSPEC_VERSION=3 ruby-ng_rspec spec/*spec.rb || die
-
- #${RUBY} -S cucumber features || die
-}