summaryrefslogtreecommitdiff
path: root/dev-ruby/shoulda/shoulda-2.11.3-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /dev-ruby/shoulda/shoulda-2.11.3-r3.ebuild
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'dev-ruby/shoulda/shoulda-2.11.3-r3.ebuild')
-rw-r--r--dev-ruby/shoulda/shoulda-2.11.3-r3.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ruby/shoulda/shoulda-2.11.3-r3.ebuild b/dev-ruby/shoulda/shoulda-2.11.3-r3.ebuild
new file mode 100644
index 000000000000..905694b9e654
--- /dev/null
+++ b/dev-ruby/shoulda/shoulda-2.11.3-r3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby25 ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_EXTRADOC="CONTRIBUTION_GUIDELINES.rdoc README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC=shoulda.gemspec
+
+inherit ruby-fakegem
+
+DESCRIPTION="Making tests easy on the fingers and eyes"
+HOMEPAGE="http://thoughtbot.com/projects/shoulda"
+SRC_URI="https://github.com/thoughtbot/${PN}/tarball/v${PV} -> ${P}.tar.gz"
+RUBY_S="thoughtbot-${PN}-*"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris ~x86-solaris"
+IUSE=""
+
+# tests seem to be quite broken :( They require working version of
+# various rails versions. There appear to be unit and matcher tests but
+# they can't be run on their own.
+RESTRICT=test