summaryrefslogtreecommitdiff
path: root/dev-ruby/shoulda-context
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-08 10:19:19 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-08 10:19:19 +0100
commit92ebda186167f9887d5f43803ced730b499dcf57 (patch)
treeee0e4261f26516d8b6bdaa4c330eee878d9ca136 /dev-ruby/shoulda-context
parentd84be18029b166ee26fe5416098974a8d05b2983 (diff)
gentoo auto-resync : 08:07:2023 - 10:19:19
Diffstat (limited to 'dev-ruby/shoulda-context')
-rw-r--r--dev-ruby/shoulda-context/Manifest2
-rw-r--r--dev-ruby/shoulda-context/shoulda-context-2.0.0.ebuild40
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-ruby/shoulda-context/Manifest b/dev-ruby/shoulda-context/Manifest
index 05d7499683fb..6969f4cbcade 100644
--- a/dev-ruby/shoulda-context/Manifest
+++ b/dev-ruby/shoulda-context/Manifest
@@ -1,3 +1,5 @@
DIST shoulda-context-1.2.2.gem 24064 BLAKE2B a6068da369c00a36e6056a8ebba96eca90efddf94613dfc90c9f2a47bec2c054a41fa61b861b2f3ec1195e417bdc54ab60d53f91bc5e0f167eac07b84880892b SHA512 b09f5ce2db59bbb26d5678b17b6641b79df7983d25e81a31bc10c42b702bdba09795b692d711d59c103beb2f691b503567e37c46668f77e600416551ef2c5e05
+DIST shoulda-context-2.0.0.gem 34304 BLAKE2B b31f7e052b54fb60fb7fff84fc48beed406864b871f3c125db4f28d1ce0f400bb0ad3479d438d20a28f585b6e5da101b71228f598e6bdc177512f048273a8524 SHA512 c8d856a95b3dfe85fd92c79f18e03a2765ad219b83ab132017fefcffd0262b04bcebf267e6bbaec0ed3dff1d4d345bd74c1f9db1d2a22938ee8d85ee1078ac6e
EBUILD shoulda-context-1.2.2-r1.ebuild 859 BLAKE2B 62cb7a49ee03073a56aa47994661813869c8cf7234ea485d1d5c967a51afa870d6f4f7477919c979b3ca219b48c6e228dc98c44736badc3d1de2bf5a0c646ac8 SHA512 c12fabefa529d8c4b4b79d279d3d2ae45f7d30605de976b207f77b375efc4d5461d7cafa68b8579c96c6ac6673495bf52add1eff214b1705cebe560fd465010f
+EBUILD shoulda-context-2.0.0.ebuild 1121 BLAKE2B 208479e7dfcfe813119e73bed1031c4f214109acf012cf3192e902ca02743e91377689d79af9c1026a9fe4b8da22f4fad6f5359da36fc611f0f61b7e6cb6293c SHA512 aabae1ebc364744434027aefcd3442512625a721aca201e61270692d6c9b3556d5c515017230127f9291f76991a83ee847bdeb98058bb301cf9a92516be06c8f
MISC metadata.xml 412 BLAKE2B cdab2c06a1407db99bd231afebddc4fd87361378cec2767b0b58c0da4fe7d3ceaa522b0a0dbede8ca496ca1840d37ac257de62f12135ffb6ea2922eac9160d84 SHA512 16fbc3b54f33c73173d09e5af860fb1e46c8498574b2f2b727e164052c8e813f25a6a75b541442469d961b515a52d5562157404136a8c00125e5c122f91a3003
diff --git a/dev-ruby/shoulda-context/shoulda-context-2.0.0.ebuild b/dev-ruby/shoulda-context/shoulda-context-2.0.0.ebuild
new file mode 100644
index 000000000000..f4025618e223
--- /dev/null
+++ b/dev-ruby/shoulda-context/shoulda-context-2.0.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby30 ruby31 ruby32"
+
+RUBY_FAKEGEM_EXTRADOC="CONTRIBUTING.md README.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL="tasks"
+
+# Don't install the conversion script to avoid collisions with older
+# shoulda.
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Context framework extracted from Shoulda"
+HOMEPAGE="https://github.com/thoughtbot/shoulda-context"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="doc test"
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit:2
+ dev-ruby/mocha )"
+
+all_ruby_prepare() {
+ sed -e '/\(current_bundle\|CurrentBundle\)/ s:^:#:' \
+ -e '/pry-byebug/ s:^:#:' \
+ -e '/warnings_logger/ s:^:#: ; /WarningsLogger/,/^)/ s:^:#:' \
+ -e '/rails_application_with_shoulda_context/ s:^:#:' \
+ -i test/test_helper.rb || die
+ rm -f test/shoulda/{railtie,rerun_snippet,test_framework_detection}_test.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:test:. -e 'Dir["test/shoulda/*_test.rb"].each { require _1 }' || die
+}