summaryrefslogtreecommitdiff
path: root/dev-ruby/shoulda-context
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
commit908778078736bd36f7a60a2d576d415cb8e000fa (patch)
treec6a4796c48b608c14dc7e9674cdbd38f905e3c15 /dev-ruby/shoulda-context
parent185fa19bbf68a4d4dca534d2b46729207a177f16 (diff)
gentoo resync : 22.05.2021
Diffstat (limited to 'dev-ruby/shoulda-context')
-rw-r--r--dev-ruby/shoulda-context/Manifest1
-rw-r--r--dev-ruby/shoulda-context/shoulda-context-1.2.2-r1.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-ruby/shoulda-context/Manifest b/dev-ruby/shoulda-context/Manifest
index 4b0710413549..24c9ed719af4 100644
--- a/dev-ruby/shoulda-context/Manifest
+++ b/dev-ruby/shoulda-context/Manifest
@@ -1,3 +1,4 @@
DIST shoulda-context-1.2.2.gem 24064 BLAKE2B a6068da369c00a36e6056a8ebba96eca90efddf94613dfc90c9f2a47bec2c054a41fa61b861b2f3ec1195e417bdc54ab60d53f91bc5e0f167eac07b84880892b SHA512 b09f5ce2db59bbb26d5678b17b6641b79df7983d25e81a31bc10c42b702bdba09795b692d711d59c103beb2f691b503567e37c46668f77e600416551ef2c5e05
+EBUILD shoulda-context-1.2.2-r1.ebuild 846 BLAKE2B d7d57110ac1d8b2429f2c368b81715d273acf77a89a8d0be562aa8710bfe4e99749abfe28ecc478f79f8636b164e7d130b9ba2386fb13468d546a8e7e9feb81d SHA512 ae180c0fab01122172d583d3a1d663063d21ad80869ae103264540f761d86ff2c234c399f7bfbf8317ba71bb5519d2ffede15286b3fda7eaa0606fc48de7f7b4
EBUILD shoulda-context-1.2.2.ebuild 877 BLAKE2B b7eebe0e276b814ad80bb7445d7ee7696a294f5c40e73974bf9d4f3ad0645c9e190a4bae9ce6e5eac4027eb2ca295cfcc5e154b460d8f69151c23e72961a9f04 SHA512 4d18f7b13d3544f09586250060b595efc6ed32f90d3d8a5092800be53118d42ca7e509786d57e2ac06c27c9f936ed580cddc62a227604d705e9a2a338caaa1a5
MISC metadata.xml 247 BLAKE2B 7717702c51c35b2a20983332abc6218047b2b5036e6b4c09d3d58b4339e8f9e776879cd116cfda60d3bcf4188859993fb9f3f779aaf595f155d53e85288f3dcc SHA512 ea4c044637b751a2c28c6ac226121e74ef18196af4b594e60413fec907bbab29c6b0c7735c3f503485df16dcfb36ddb86038394d92e2cd18c8f04626628e9f09
diff --git a/dev-ruby/shoulda-context/shoulda-context-1.2.2-r1.ebuild b/dev-ruby/shoulda-context/shoulda-context-1.2.2-r1.ebuild
new file mode 100644
index 000000000000..11edf3357612
--- /dev/null
+++ b/dev-ruby/shoulda-context/shoulda-context-1.2.2-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby25 ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_EXTRADOC="CONTRIBUTING.md README.md"
+
+RUBY_FAKEGEM_EXTRAINSTALL="init.rb rails tasks"
+
+# Don't install the conversion script to avoid collisions with older
+# shoulda.
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Context framework extracted from Shoulda"
+HOMEPAGE="https://github.com/thoughtbot/shoulda-context"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc test"
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit:2
+ <dev-ruby/mocha-1 )"
+
+all_ruby_prepare() {
+ sed -i -e "1igem 'mocha', '~>0.10'\n" test/test_helper.rb || die
+}
+
+each_ruby_test() {
+ BUNDLE_GEMFILE=x ruby-ng_testrb-2 -Itest test/shoulda/*_test.rb || die
+}