summaryrefslogtreecommitdiff
path: root/dev-ruby/shoulda-context
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-11-04 03:03:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-11-04 03:03:54 +0000
commit3cc82055be7dba177f4aea15af9f5414b532da7e (patch)
tree1eed8bbe7a93b3a0a7d6091ead40e81519978a38 /dev-ruby/shoulda-context
parent212000bb5eabdfeb9a6e7a9b8f28e2740cae555a (diff)
gentoo auto-resync : 04:11:2024 - 03:03:54
Diffstat (limited to 'dev-ruby/shoulda-context')
-rw-r--r--dev-ruby/shoulda-context/Manifest1
-rw-r--r--dev-ruby/shoulda-context/shoulda-context-2.0.0.ebuild40
2 files changed, 0 insertions, 41 deletions
diff --git a/dev-ruby/shoulda-context/Manifest b/dev-ruby/shoulda-context/Manifest
index aef905d5e310..740f08dedae1 100644
--- a/dev-ruby/shoulda-context/Manifest
+++ b/dev-ruby/shoulda-context/Manifest
@@ -3,5 +3,4 @@ DIST shoulda-context-1.2.2.gem 24064 BLAKE2B a6068da369c00a36e6056a8ebba96eca90e
DIST shoulda-context-2.0.0.gem 34304 BLAKE2B b31f7e052b54fb60fb7fff84fc48beed406864b871f3c125db4f28d1ce0f400bb0ad3479d438d20a28f585b6e5da101b71228f598e6bdc177512f048273a8524 SHA512 c8d856a95b3dfe85fd92c79f18e03a2765ad219b83ab132017fefcffd0262b04bcebf267e6bbaec0ed3dff1d4d345bd74c1f9db1d2a22938ee8d85ee1078ac6e
EBUILD shoulda-context-1.2.2-r1.ebuild 859 BLAKE2B 62cb7a49ee03073a56aa47994661813869c8cf7234ea485d1d5c967a51afa870d6f4f7477919c979b3ca219b48c6e228dc98c44736badc3d1de2bf5a0c646ac8 SHA512 c12fabefa529d8c4b4b79d279d3d2ae45f7d30605de976b207f77b375efc4d5461d7cafa68b8579c96c6ac6673495bf52add1eff214b1705cebe560fd465010f
EBUILD shoulda-context-2.0.0-r1.ebuild 1170 BLAKE2B c888efdd0d757d30a1dd11490abbdbfc1304fa6baf5c417500228d71678044757e4c93e6286fa38a703c4736561951902bff0e0a8b85fb575b4d42e27e80766a SHA512 290b1f7a811c310e1e3974175f2f73ccfa7feae8f8d4df13593275d672a423c8c45f7c105c16878d4001ee22048794725d28666932f33da51eef780801df895c
-EBUILD shoulda-context-2.0.0.ebuild 1120 BLAKE2B 28a66e13eda3058a3e722adf85b4b01847af0e31965bffa88778baa0aaff3fe2c1d776cc13563fd25ca49f8921a40ae7c10a5a4699a599dd6a062daff8dcb17d SHA512 454d8d4f805892218cf637c7ee3181bdd7d0d1002f6a57602f024b7ed52015a8cca7a656786e613838a1ce90ff5e863cc35e75d4089069268c0407e245d741e0
MISC metadata.xml 412 BLAKE2B cdab2c06a1407db99bd231afebddc4fd87361378cec2767b0b58c0da4fe7d3ceaa522b0a0dbede8ca496ca1840d37ac257de62f12135ffb6ea2922eac9160d84 SHA512 16fbc3b54f33c73173d09e5af860fb1e46c8498574b2f2b727e164052c8e813f25a6a75b541442469d961b515a52d5562157404136a8c00125e5c122f91a3003
diff --git a/dev-ruby/shoulda-context/shoulda-context-2.0.0.ebuild b/dev-ruby/shoulda-context/shoulda-context-2.0.0.ebuild
deleted file mode 100644
index 5a6a7399f6e7..000000000000
--- a/dev-ruby/shoulda-context/shoulda-context-2.0.0.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-USE_RUBY="ruby30 ruby31 ruby32"
-
-RUBY_FAKEGEM_EXTRADOC="CONTRIBUTING.md README.md"
-
-RUBY_FAKEGEM_EXTRAINSTALL="tasks"
-
-# Don't install the conversion script to avoid collisions with older
-# shoulda.
-RUBY_FAKEGEM_BINWRAP=""
-
-inherit ruby-fakegem
-
-DESCRIPTION="Context framework extracted from Shoulda"
-HOMEPAGE="https://github.com/thoughtbot/shoulda-context"
-
-LICENSE="MIT"
-SLOT="$(ver_cut 1)"
-KEYWORDS="amd64 arm arm64 ~hppa ~loong ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE="doc test"
-
-ruby_add_bdepend "test? ( dev-ruby/test-unit:2
- >=dev-ruby/mocha-1.0 )"
-
-all_ruby_prepare() {
- sed -e '/\(current_bundle\|CurrentBundle\)/ s:^:#:' \
- -e '/pry-byebug/ s:^:#:' \
- -e '/warnings_logger/ s:^:#: ; /WarningsLogger/,/^)/ s:^:#:' \
- -e '/rails_application_with_shoulda_context/ s:^:#:' \
- -i test/test_helper.rb || die
- rm -f test/shoulda/{railtie,rerun_snippet,test_framework_detection}_test.rb || die
-}
-
-each_ruby_test() {
- ${RUBY} -Ilib:test:. -e 'Dir["test/shoulda/*_test.rb"].each { require _1 }' || die
-}