summaryrefslogtreecommitdiff
path: root/dev-ruby/shotgun/shotgun-0.9.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/shotgun/shotgun-0.9.2.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/shotgun/shotgun-0.9.2.ebuild')
-rw-r--r--dev-ruby/shotgun/shotgun-0.9.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ruby/shotgun/shotgun-0.9.2.ebuild b/dev-ruby/shotgun/shotgun-0.9.2.ebuild
new file mode 100644
index 000000000000..c3733183621e
--- /dev/null
+++ b/dev-ruby/shotgun/shotgun-0.9.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby22 ruby23 ruby24"
+
+# No documentation task
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Forking implementation of rackup"
+HOMEPAGE="https://github.com/rtomayko/shotgun"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# Warning: the code does not use gem versioning to make sure to load
+# only the right rack version so we might need to patch it to work :/
+ruby_add_rdepend 'dev-ruby/rack:*'
+ruby_add_bdepend "test? ( dev-ruby/bacon )"
+
+each_ruby_test() {
+ ${RUBY} -Ilib test/test_shotgun_static.rb || die
+ ${RUBY} -Ilib test/test_shotgun_loader.rb || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman man/shotgun.1
+}