summaryrefslogtreecommitdiff
path: root/dev-ruby/sfl/sfl-2.2-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
commit7f0ccc917c7abe6223784c703d86cd14755691fb (patch)
tree8c6793f68896b341e22f33d7e6cef88e481f4a8b /dev-ruby/sfl/sfl-2.2-r2.ebuild
parent9aa80713372911cec499b3adb2cd746790920916 (diff)
gentoo resync : 03.07.2021
Diffstat (limited to 'dev-ruby/sfl/sfl-2.2-r2.ebuild')
-rw-r--r--dev-ruby/sfl/sfl-2.2-r2.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/sfl/sfl-2.2-r2.ebuild b/dev-ruby/sfl/sfl-2.2-r2.ebuild
new file mode 100644
index 000000000000..bf0d43ccff3a
--- /dev/null
+++ b/dev-ruby/sfl/sfl-2.2-r2.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Library providing spawn() which is almost perfectly compatible with ruby 1.9's"
+HOMEPAGE="https://github.com/ujihisa/spawn-for-legacy"
+
+LICENSE="|| ( Ruby BSD-2 )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+
+IUSE=""
+
+all_ruby_prepare() {
+ rm -f Gemfile* || die
+ sed -i -e "s:/tmp:${TMPDIR}:" spec/sfl_spec.rb || die
+}