summaryrefslogtreecommitdiff
path: root/dev-ruby/selenium-webdriver
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
committerV3n3RiX <venerix@koprulu.sector>2021-10-20 10:22:14 +0100
commit46eedbedafdb0040c37884982d4c775ce277fb7b (patch)
treedb33a91259730be84999e13a8d8168c799f50ac0 /dev-ruby/selenium-webdriver
parente23a08d0c97a0cc415aaa165da840b056f93c997 (diff)
gentoo resync : 20.10.2021
Diffstat (limited to 'dev-ruby/selenium-webdriver')
-rw-r--r--dev-ruby/selenium-webdriver/Manifest2
-rw-r--r--dev-ruby/selenium-webdriver/selenium-webdriver-4.0.0.ebuild36
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-ruby/selenium-webdriver/Manifest b/dev-ruby/selenium-webdriver/Manifest
index 4c5ea35e024a..007944c1a358 100644
--- a/dev-ruby/selenium-webdriver/Manifest
+++ b/dev-ruby/selenium-webdriver/Manifest
@@ -1,3 +1,5 @@
DIST selenium-webdriver-3.142.7.gem 865280 BLAKE2B 650011848afaa3ea4fab7c8172828c7562df212383a8fbea9615a5136e3382aba0fcf17952d941c7b514e5229c0aafe3dbc320386698eb8756f567eff67722bd SHA512 0e7891c19b8a0b20441d85bc17032ecf03cba7ca435846e03abc50b62b0c53c075dc70456796c9bfcd1ecd28ecc517f907a3d6868346a07617fd1d0c1b9437c0
+DIST selenium-webdriver-4.0.0.gem 152576 BLAKE2B 8a1394fb1c9cc3603081454c4946f0ad5207d113bb37c488207baaaaaff69f2848b2b5bc9b9221177d01c86b635dd222933be3561eacfa164539c99c8cf149a6 SHA512 db8fd0a05fc38e7f55c2b9a779462416b937d3b8e732dee6b7bcf2b3f8914417a79e8649e320e348359ab133cef20a75e2033385e8b125e5dfc52645b086045b
EBUILD selenium-webdriver-3.142.7-r1.ebuild 1105 BLAKE2B fbd7aec91d8f5eae4a45a29c01309d7facc0e3a73ffeae3fc3a5c81b3ed551d2fbe70f61ec52225f07fa709c80eea8bec13153ac7a1484d6334b8df752c2e74c SHA512 fcc13f25d587994c569c9f7ae6da5430d50a032a7ee13fdd5010d4c9de0da97cbb188760adc059bdc2e15ba6568ee4ac18c0a82af61053b7d425f26300f2f8b9
+EBUILD selenium-webdriver-4.0.0.ebuild 1015 BLAKE2B df6b7d93c12ab49c58fd76b561597beac3452d7e41075a04fac82ac1282e43846924232015f73506ddd6c11856cca27fee8eb8e51f4587dc19f8eeb4ae941207 SHA512 2a272f961e101c996dcc4b7cacbac94dc5257e95fa6d07ac9fd4f6815273873a376482b09079dbaedbcf50e5cfd6bc59c75c2a35fe152ceffdebf6daa1cbae5b
MISC metadata.xml 336 BLAKE2B 2133927d6a27b7422141ed649e46efc069300160b5fecb9fb5bdbf575461fde2b12411696be46cc673d6996c8711f50a46e92e1cdda5ff1f7c57ae298ff76406 SHA512 d1f80b8bf35f2fd08e4689292ce535ece939a64b94123780206d4ee3ab7a20b6d9c3a2d9f5248eaa2d0d35bb32bc5707e14c09b60881d856a180435b8f656bea
diff --git a/dev-ruby/selenium-webdriver/selenium-webdriver-4.0.0.ebuild b/dev-ruby/selenium-webdriver/selenium-webdriver-4.0.0.ebuild
new file mode 100644
index 000000000000..48a9afa6621d
--- /dev/null
+++ b/dev-ruby/selenium-webdriver/selenium-webdriver-4.0.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby26 ruby27 ruby30"
+
+# NOTE: this package contains precompiled code. It appears that all
+# source code can be found at https://code.google.com/p/selenium/ but the
+# repository is not organized in a way so that we can easily rebuild the
+# suited shared object. We'll just try our luck with the precompiled
+# objects for now.
+
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="CHANGES README.md"
+
+RUBY_FAKEGEM_TASK_TEST=""
+
+RUBY_FAKEGEM_GEMSPEC="selenium-webdriver.gemspec"
+
+RUBY_QA_ALLOWED_LIBS="x_ignore_nofocus.so"
+QA_PREBUILT="*/x_ignore_nofocus.so"
+
+inherit ruby-fakegem
+
+DESCRIPTION="This gem provides Ruby bindings for WebDriver"
+HOMEPAGE="https://github.com/seleniumhq/selenium"
+
+LICENSE="Apache-2.0"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/childprocess-0.5:2
+ >=dev-ruby/rexml-3.2.5:3
+ >=dev-ruby/rubyzip-1.2.2:*"