summaryrefslogtreecommitdiff
path: root/dev-ruby/safe_yaml/safe_yaml-1.0.5-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /dev-ruby/safe_yaml/safe_yaml-1.0.5-r1.ebuild
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'dev-ruby/safe_yaml/safe_yaml-1.0.5-r1.ebuild')
-rw-r--r--dev-ruby/safe_yaml/safe_yaml-1.0.5-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-ruby/safe_yaml/safe_yaml-1.0.5-r1.ebuild b/dev-ruby/safe_yaml/safe_yaml-1.0.5-r1.ebuild
new file mode 100644
index 000000000000..ea0cd393ddd8
--- /dev/null
+++ b/dev-ruby/safe_yaml/safe_yaml-1.0.5-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Parse YAML safely, alternative implementation of YAML.load"
+HOMEPAGE="https://dtao.github.com/safe_yaml"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~sparc ~x86 ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+ruby_add_bdepend "test? ( dev-ruby/hashie
+ dev-ruby/heredoc_unindent
+ dev-ruby/rspec:3 )"
+
+all_ruby_prepare() {
+ sed -i -e '/local timezone/askip "timezone"' spec/transform/to_date_spec.rb || die
+}
+
+each_ruby_test() {
+ # Run specs with monkeypatch
+ ${RUBY} -S rspec-3 spec --tag ~libraries || die
+
+ # Running specs without monkeypatch
+ ${RUBY} -S rspec-3 spec --tag libraries || die
+}