summaryrefslogtreecommitdiff
path: root/dev-ruby/rubyzip
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/rubyzip
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/rubyzip')
-rw-r--r--dev-ruby/rubyzip/Manifest3
-rw-r--r--dev-ruby/rubyzip/metadata.xml11
-rw-r--r--dev-ruby/rubyzip/rubyzip-1.2.1.ebuild47
3 files changed, 61 insertions, 0 deletions
diff --git a/dev-ruby/rubyzip/Manifest b/dev-ruby/rubyzip/Manifest
new file mode 100644
index 000000000000..b1a8333d95b2
--- /dev/null
+++ b/dev-ruby/rubyzip/Manifest
@@ -0,0 +1,3 @@
+DIST rubyzip-1.2.1-git.tgz 151085 BLAKE2B e7053dd3fcb95d6850368c927a0a549a85a8d45c64538e27e21ce824035121e6333a86d65ae84aa1d309aff5f0f335bbfd489871d8d8bae31b3a1c78ed181a14 SHA512 ba71d293120943142608b617d76d72699c64b92a6bf602543a3f42f01c44eea3f0c902bc841a2aaf9cffac4a2ba02a47a847115eca1093587d944c2f4acc9b9e
+EBUILD rubyzip-1.2.1.ebuild 1171 BLAKE2B e26e8b0b6346abbcbfa79dab8c5d2cad18404aba7e1ced41257bec05e9a65d2223616adc6cd0facb2ce509d768a9ddfe60491a167e2aac128c9e85e9a190d4de SHA512 d89655c979d01fbd5dc8e51050030105e351f9a0efa54d30d8a303ba681509036b6ea58c7171cf3f1ba5df7bd875075fa0a70defb02b112b74402dd052d25ac6
+MISC metadata.xml 341 BLAKE2B 2e04f2f0e3ee64a4d476ca38f166efc94dad160850cd08b42ed54e68a275ec1d26b76a751bf9a347da5f9c8851575a8a58b9021f91acd1a733be536f947e6743 SHA512 7928d7e4a5dcaeb924d44348981910cf0024939f6f169a00df46fcd80cc933b56e91423e8919ef7a74f03e4bc1eda7b7f8a8bc6e954f6195989c1a9eb574cf3f
diff --git a/dev-ruby/rubyzip/metadata.xml b/dev-ruby/rubyzip/metadata.xml
new file mode 100644
index 000000000000..76f8aac4920f
--- /dev/null
+++ b/dev-ruby/rubyzip/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">rubyzip/rubyzip</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/rubyzip/rubyzip-1.2.1.ebuild b/dev-ruby/rubyzip/rubyzip-1.2.1.ebuild
new file mode 100644
index 000000000000..10d98b69428f
--- /dev/null
+++ b/dev-ruby/rubyzip/rubyzip-1.2.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md TODO"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A ruby library for reading and writing zip files"
+HOMEPAGE="https://github.com/rubyzip/rubyzip"
+# Tests are not included in the gem.
+SRC_URI="https://github.com/rubyzip/rubyzip/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+LICENSE="Ruby"
+SLOT="1"
+KEYWORDS="alpha amd64 arm ~arm64 hppa ~ia64 ppc ppc64 ~sparc x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${DEPEND} test? ( app-arch/zip )"
+
+ruby_add_bdepend "test? ( dev-ruby/minitest:5 )"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ docinto examples
+ dodoc samples/*
+}
+
+all_ruby_prepare() {
+ # Avoid dependencies on simplecov and coveralls
+ sed -i -e '/simplecov/ s:^:#:' test/test_helper.rb || die
+
+ # Avoid dependency on bundler
+ sed -i -e '/bundler/ s:^:#:' Rakefile || die
+
+ # Fix hardcoded path to /tmp
+ sed -i -e 's:/tmp/:'${T}'/:g' test/entry_test.rb || die
+
+ # Add missing require
+ sed -i -e '1irequire "forwardable"' test/input_stream_test.rb || die
+}