summaryrefslogtreecommitdiff
path: root/dev-ruby/rubyzip/rubyzip-2.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /dev-ruby/rubyzip/rubyzip-2.0.0.ebuild
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'dev-ruby/rubyzip/rubyzip-2.0.0.ebuild')
-rw-r--r--dev-ruby/rubyzip/rubyzip-2.0.0.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/dev-ruby/rubyzip/rubyzip-2.0.0.ebuild b/dev-ruby/rubyzip/rubyzip-2.0.0.ebuild
deleted file mode 100644
index 510531b3cc18..000000000000
--- a/dev-ruby/rubyzip/rubyzip-2.0.0.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-USE_RUBY="ruby24 ruby25 ruby26 ruby27"
-
-RUBY_FAKEGEM_RECIPE_DOC="none"
-RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md TODO"
-
-RUBY_FAKEGEM_GEMSPEC="rubyzip.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A ruby library for reading and writing zip files"
-HOMEPAGE="https://github.com/rubyzip/rubyzip"
-# Tests are not included in the gem.
-SRC_URI="https://github.com/rubyzip/rubyzip/archive/v${PV}.tar.gz -> ${P}-git.tgz"
-
-LICENSE="Ruby"
-SLOT="$(ver_cut 1)"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE=""
-
-RDEPEND=""
-DEPEND="${DEPEND} test? ( app-arch/zip )"
-
-ruby_add_bdepend "test? ( dev-ruby/minitest:5 )"
-
-all_ruby_install() {
- all_fakegem_install
-
- docinto examples
- dodoc samples/*
-}
-
-all_ruby_prepare() {
- # Avoid dependencies on simplecov and coveralls
- sed -i -e '/simplecov/ s:^:#:' test/test_helper.rb || die
-
- # Avoid dependency on bundler
- sed -i -e '/bundler/ s:^:#:' Rakefile || die
-
- # Fix hardcoded path to /tmp
- sed -i -e 's:/tmp/:'${T}'/:g' test/entry_test.rb || die
-
- # Add missing requires
- sed -i -e '1irequire "forwardable"; require "pathname"' test/input_stream_test.rb || die
-}