summaryrefslogtreecommitdiff
path: root/dev-ruby/rubyzip/rubyzip-1.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-02 05:16:35 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-02 05:16:35 +0100
commit6882d8d1110ef4feeec532196a1f0a25420d0fd1 (patch)
treec8a3d28a31e6c077d6b9097ff36b1232d2ce04b7 /dev-ruby/rubyzip/rubyzip-1.3.0.ebuild
parent85a2a2153ef8027c2ba1be45143cd91914be0ad0 (diff)
gentoo auto-resync : 02:04:2023 - 05:16:35
Diffstat (limited to 'dev-ruby/rubyzip/rubyzip-1.3.0.ebuild')
-rw-r--r--dev-ruby/rubyzip/rubyzip-1.3.0.ebuild52
1 files changed, 0 insertions, 52 deletions
diff --git a/dev-ruby/rubyzip/rubyzip-1.3.0.ebuild b/dev-ruby/rubyzip/rubyzip-1.3.0.ebuild
deleted file mode 100644
index 6b26c9dd8e19..000000000000
--- a/dev-ruby/rubyzip/rubyzip-1.3.0.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-USE_RUBY="ruby25 ruby26 ruby27 ruby30"
-
-RUBY_FAKEGEM_RECIPE_DOC="none"
-RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md TODO"
-
-RUBY_FAKEGEM_GEMSPEC="rubyzip.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A ruby library for reading and writing zip files"
-HOMEPAGE="https://github.com/rubyzip/rubyzip"
-# Tests are not included in the gem.
-SRC_URI="https://github.com/rubyzip/rubyzip/archive/v${PV}.tar.gz -> ${P}-git.tgz"
-
-LICENSE="Ruby-BSD"
-SLOT="1"
-KEYWORDS="amd64 arm arm64 ~hppa ppc ppc64 sparc x86"
-IUSE=""
-
-RDEPEND=""
-DEPEND="${DEPEND} test? ( app-arch/zip )"
-
-ruby_add_bdepend "test? ( dev-ruby/minitest:5 )"
-
-all_ruby_install() {
- all_fakegem_install
-
- docinto examples
- dodoc samples/*
-}
-
-all_ruby_prepare() {
- # Avoid dependencies on simplecov and coveralls
- sed -i -e '/simplecov/ s:^:#:' test/test_helper.rb || die
-
- # Avoid dependency on bundler
- sed -i -e '/bundler/ s:^:#:' Rakefile || die
-
- # Fix hardcoded path to /tmp
- sed -i -e "s:/tmp/:${T}/:g" test/entry_test.rb || die
-
- # Add missing requires
- sed -i -e '1irequire "forwardable"; require "pathname"' test/input_stream_test.rb || die
-
- # Fix broken test that uses native endian
- sed -i -e '/pack/ s/LLS/VVv/' test/file_extract_test.rb || die
-}