summaryrefslogtreecommitdiff
path: root/dev-ruby/ruby_version
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-18 14:34:47 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-18 14:34:47 +0100
commit3a1b8b124a5b405562b6e0ccf04e7bd2ddc131a4 (patch)
tree586b06fa140c17c92f004998807e894c1874db27 /dev-ruby/ruby_version
parente0d23d9d2468ec36070ef9fa63bd814db6a653da (diff)
gentoo auto-resync : 18:07:2022 - 14:34:47
Diffstat (limited to 'dev-ruby/ruby_version')
-rw-r--r--dev-ruby/ruby_version/Manifest3
-rw-r--r--dev-ruby/ruby_version/metadata.xml11
-rw-r--r--dev-ruby/ruby_version/ruby_version-1.0.2.ebuild18
3 files changed, 32 insertions, 0 deletions
diff --git a/dev-ruby/ruby_version/Manifest b/dev-ruby/ruby_version/Manifest
new file mode 100644
index 000000000000..75bd049129d6
--- /dev/null
+++ b/dev-ruby/ruby_version/Manifest
@@ -0,0 +1,3 @@
+DIST ruby_version-1.0.2.gem 24576 BLAKE2B 93283e11d49a4b981a64b7e61c68b93ab7abbc91c20de152e1936a1d57db54eec7e8d3aa756f96e52a531a3d72891724f53d3bc39f85e3be70d06d2958abef4d SHA512 638fa85d768a3975bd3eddbe71ef4c44a0cb4d135b44f746b1636cc02cdb4313331e41e35f7ed4f4a0132758d8264995ac8aa3e121abbeae5b95c62fe0d9132c
+EBUILD ruby_version-1.0.2.ebuild 477 BLAKE2B 7f8c9505f66ea29417f9f543f7b9d04d6033ad56f6c3b9a6aef05543e8eb3e15ead35cdf107ff4ff8f6085d0e9220564a9b2129b3a16763080d7af118e9fa489 SHA512 b3550e5b400a8ba08e00c2b53ce848d199c46c3b0a1275ad7b4f03df3049a7b260ebc8c495597bcef738eabc75e9951753de5c541d1c14f7a786e7f50bddf23e
+MISC metadata.xml 338 BLAKE2B 3c631f5aaf66c50cbccaa3105c723c7d7be60e7cb7f498b8b96a93744a5f57ad506112782f5591eab6d391a9ce86e61f92afadfeb59896d90a9a5d93aeb6fef2 SHA512 f6b971f926a0b74f85e7f8ad7ef3a456b5279e899d26d296629373891f44752fe860697101108c94213e201d2e2d0422c2d6f6c208e9aca16d20887e1ef78d70
diff --git a/dev-ruby/ruby_version/metadata.xml b/dev-ruby/ruby_version/metadata.xml
new file mode 100644
index 000000000000..b3209d9c58f8
--- /dev/null
+++ b/dev-ruby/ruby_version/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">janlelis/ruby_version</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/ruby_version/ruby_version-1.0.2.ebuild b/dev-ruby/ruby_version/ruby_version-1.0.2.ebuild
new file mode 100644
index 000000000000..3cdc0b667262
--- /dev/null
+++ b/dev-ruby/ruby_version/ruby_version-1.0.2.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_EXTRADOC="ChangeLog.md README.rdoc"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Provides a RubyVersion class which offers a convenient DSL for checking for the right Ruby version"
+HOMEPAGE="https://github.com/janlelis/ruby_version"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64"
+IUSE=""