summaryrefslogtreecommitdiff
path: root/dev-ruby/ruby_parser/ruby_parser-3.14.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-ruby/ruby_parser/ruby_parser-3.14.1.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-ruby/ruby_parser/ruby_parser-3.14.1.ebuild')
-rw-r--r--dev-ruby/ruby_parser/ruby_parser-3.14.1.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-ruby/ruby_parser/ruby_parser-3.14.1.ebuild b/dev-ruby/ruby_parser/ruby_parser-3.14.1.ebuild
deleted file mode 100644
index cc09e5c49971..000000000000
--- a/dev-ruby/ruby_parser/ruby_parser-3.14.1.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-USE_RUBY="ruby24 ruby25 ruby26 ruby27"
-
-RUBY_FAKEGEM_EXTRADOC="README.rdoc History.rdoc"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A ruby parser written in pure ruby"
-HOMEPAGE="https://github.com/seattlerb/ruby_parser"
-
-LICENSE="MIT"
-SLOT="3"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-ruby_add_rdepend ">=dev-ruby/sexp_processor-4.9.0:4"
-
-ruby_add_bdepend "test? ( dev-ruby/racc >=dev-ruby/minitest-4.3 >=dev-ruby/sexp_processor-4.13.0:4 )"
-
-DEPEND+=" test? ( dev-util/unifdef )"
-
-all_ruby_prepare() {
- # Remove reference to perforce method that is not in a released
- # version of hoe-seattlerb.
- #sed -i -e '/perforce/d' Rakefile || die
- sed -i -e '/license/d' Rakefile || die
- sed -i -e '/Hoe.plugin :isolate/ s:^:#:' Rakefile || die
-}
-
-each_ruby_test() {
- ${RUBY} -Ilib:. -e 'Dir["test/test_*.rb"].each{|f| require f}' || die
-}