summaryrefslogtreecommitdiff
path: root/dev-ruby/ruby_gntp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/ruby_gntp
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/ruby_gntp')
-rw-r--r--dev-ruby/ruby_gntp/Manifest3
-rw-r--r--dev-ruby/ruby_gntp/metadata.xml11
-rw-r--r--dev-ruby/ruby_gntp/ruby_gntp-0.3.4.ebuild29
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-ruby/ruby_gntp/Manifest b/dev-ruby/ruby_gntp/Manifest
new file mode 100644
index 000000000000..831a217142a6
--- /dev/null
+++ b/dev-ruby/ruby_gntp/Manifest
@@ -0,0 +1,3 @@
+DIST ruby_gntp-0.3.4.gem 10240 BLAKE2B dff0f192ee0308793171f0233379b41e8ff8cf8e3af3497c5f04f323dc5f75d4f310f2fc21538beda271f4d3bedc8fcad200afe7b4d24ec864e023346c5899c6 SHA512 876b728430183b273bf97a7e7b662c0614bcc21a3d1a7c4c07b2af9b1643c9a9bc96e92843e6118903d75d99b21c2faff0f27c22fbc8822db14560937e6a5dd8
+EBUILD ruby_gntp-0.3.4.ebuild 630 BLAKE2B e9babb79d673dd93aec222cff5ba44238d180012b7905eb50e896a9c568bb0587259ae0d425222f9330a7b43972fcc2e303e2ae2ae4e284c9436162f90b51a05 SHA512 c30dee87059825c491ece0cb0af4a5ba423d210f2762a65065be821534e606b80732c00a8ac339001d30331cc34926744a26448ed10416cedc1f83b5931d7365
+MISC metadata.xml 341 BLAKE2B 350d0f741bfb75faaaef8c129e8d124acfe96ee11b8005213392d94bc6e41bc2bc6f8654dec2d802a48fdf17f78db0e02785bc18dab1aceb85e757a9b079110e SHA512 da71900b8e637cb46023f4ac7e82b86a12b6858d8078b173501f616be53d219a1d6033ff5015500572c1ffe33dec6098256a5a6eb20c1a0b901210ad39bb47fc
diff --git a/dev-ruby/ruby_gntp/metadata.xml b/dev-ruby/ruby_gntp/metadata.xml
new file mode 100644
index 000000000000..f142ffd9b203
--- /dev/null
+++ b/dev-ruby/ruby_gntp/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">snaka/ruby_gntp</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/ruby_gntp/ruby_gntp-0.3.4.ebuild b/dev-ruby/ruby_gntp/ruby_gntp-0.3.4.ebuild
new file mode 100644
index 000000000000..5398a9eaa771
--- /dev/null
+++ b/dev-ruby/ruby_gntp/ruby_gntp-0.3.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README ChangeLog"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Ruby library for GNTP(Growl Notification Transport Protocol)"
+HOMEPAGE="https://github.com/snaka/ruby_gntp"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+ruby_add_bdepend "test? ( dev-ruby/rr )"
+
+all_ruby_prepare() {
+ mv test spec || die
+ sed -i -e "s/Spec::Runner/RSpec/" \
+ -e "s#\.\./lib/##"\
+ spec/ruby_gntp_spec.rb || die
+
+}