summaryrefslogtreecommitdiff
path: root/dev-ruby/ruby-termios
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/ruby-termios
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/ruby-termios')
-rw-r--r--dev-ruby/ruby-termios/Manifest3
-rw-r--r--dev-ruby/ruby-termios/metadata.xml11
-rw-r--r--dev-ruby/ruby-termios/ruby-termios-1.0.2-r1.ebuild32
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-ruby/ruby-termios/Manifest b/dev-ruby/ruby-termios/Manifest
new file mode 100644
index 000000000000..edac70fd4a8f
--- /dev/null
+++ b/dev-ruby/ruby-termios/Manifest
@@ -0,0 +1,3 @@
+DIST ruby-termios-1.0.2.gem 17408 BLAKE2B f85877dc3c9beb5c8d20e044ef7dfde6a12d540157228c1fdff365f3b662f8c84b9e7460ede985f0d402ec76a1d248fa41d336ac7bd9333222543c6d01748c83 SHA512 e32e899e917eb04e382a02484accf9fea0369de8c1942b445e48e71e9c836305e2d54221c9a044d27ede44a7d5c14f976a8ffda79f79f71b5a121474e759f45d
+EBUILD ruby-termios-1.0.2-r1.ebuild 728 BLAKE2B 40c46c7da5e7523a4e9b6820c635bca48bfff02a2d828a8db427c33a1cc3aead6a6a791bb5ef5b4e0e97c2c771077f43e5c0cf08a30941cd329f11489707ca51 SHA512 ea214f241021a4c25be2c301ddd542671aa1db3c5163034e39ac4f925bb4fbf60182ce272bd01a398b4677a41705419f3abf64a658d8f79153dcd3191e25bebc
+MISC metadata.xml 344 BLAKE2B bea737f016d7562c237c3cd1da976866362b52c33fed4f356becc724318f0d73129d6d67cb1202658495cd3ca337625f218cf3739dcdb19fab7fbf7df87df8bc SHA512 3c6d07c1fb48f63b2e3b11eaa84b24b6f57e1b7ad4146327950c294e0d49521a7dce7cb63c99bd0641c7b330d64b6c85d91ba6feb150282f35902fce8602806c
diff --git a/dev-ruby/ruby-termios/metadata.xml b/dev-ruby/ruby-termios/metadata.xml
new file mode 100644
index 000000000000..3ae483f3b3a8
--- /dev/null
+++ b/dev-ruby/ruby-termios/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">arika/ruby-termios</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/ruby-termios/ruby-termios-1.0.2-r1.ebuild b/dev-ruby/ruby-termios/ruby-termios-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..23e9fbd36d15
--- /dev/null
+++ b/dev-ruby/ruby-termios/ruby-termios-1.0.2-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="README.md termios.rd"
+
+# There are no tests in the gem, and the upstream tests only work
+# with a normal TTY, bug 340575.
+RUBY_FAKEGEM_RECIPE_TEST="none"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="A Ruby interface to termios"
+HOMEPAGE="http://arika.org/ruby/termios"
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="amd64 ~hppa ~mips ~ppc x86 ~x86-macos"
+IUSE=""
+
+each_ruby_configure() {
+ ${RUBY} -Cext extconf.rb || die
+}
+
+each_ruby_compile() {
+ emake -Cext V=1
+ cp ext/termios$(get_modname) lib/ || die
+}