summaryrefslogtreecommitdiff
path: root/dev-ruby/ruby-sdl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/ruby-sdl
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/ruby-sdl')
-rw-r--r--dev-ruby/ruby-sdl/Manifest3
-rw-r--r--dev-ruby/ruby-sdl/metadata.xml16
-rw-r--r--dev-ruby/ruby-sdl/ruby-sdl-2.1.2-r2.ebuild68
3 files changed, 87 insertions, 0 deletions
diff --git a/dev-ruby/ruby-sdl/Manifest b/dev-ruby/ruby-sdl/Manifest
new file mode 100644
index 000000000000..bafc1dbe0fb8
--- /dev/null
+++ b/dev-ruby/ruby-sdl/Manifest
@@ -0,0 +1,3 @@
+DIST ruby-sdl-2.1.2.tar.gz 178105 BLAKE2B 84870279edcf2616159861267ffc8666b482786f43a30c8729cd4c59f25219956648270452bf38b72115e05235786ec8c0f0e7913469cc8573d9eda813d25726 SHA512 1ddae367fb4145cc8142edbf3c61acaf56604054f710ac37cadb8d04f93db24fc3595c1bc8e0fb5f330aabc815884f31b5f2a39c0108026fca442fc0b3bc2807
+EBUILD ruby-sdl-2.1.2-r2.ebuild 1962 BLAKE2B bceec5bbbe15cdb11db6c25663e7d664ca2a933eca17ddba3807c4f8da01c65ae270fbcc876bba10f279bc843ce6de9293b1a2fe12051cf5009740d9ee8ea7f3 SHA512 351a1507979bca28474a7051e5601e0ab2cd6c8c1c1ca9f766180d3ac8714f8860a645a630d244d009b875f4854939bd8bb02fc87577b2bb38cbd6afb51dc0d7
+MISC metadata.xml 560 BLAKE2B 44c2c964436b58f2f3d088cc598db576b71e5f42a490e1ae616400686addaf188c82b0f5a4dfab56a61712d5858720007fb31df3f6b71d0e37e5b617dde67984 SHA512 a9eaf9e6a1cf02821fec770e3499796993aebfdf0a7f251773a12950cd42770beb1d5bbc34fad694e74522eeeea619cd659509c31f914f4ddd257a9ce1c17fbb
diff --git a/dev-ruby/ruby-sdl/metadata.xml b/dev-ruby/ruby-sdl/metadata.xml
new file mode 100644
index 000000000000..bc5eb37a99e2
--- /dev/null
+++ b/dev-ruby/ruby-sdl/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <use>
+ <flag name="image">Enable <pkg>media-libs/sdl-image</pkg> support</flag>
+ <flag name="mixer">Enable <pkg>media-libs/sdl-mixer</pkg> support</flag>
+ <flag name="sge">Enable sdl-sge support</flag>
+ </use>
+ <upstream>
+ <remote-id type="github">ohai/rubysdl</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/ruby-sdl/ruby-sdl-2.1.2-r2.ebuild b/dev-ruby/ruby-sdl/ruby-sdl-2.1.2-r2.ebuild
new file mode 100644
index 000000000000..ca4a0d9ed640
--- /dev/null
+++ b/dev-ruby/ruby-sdl/ruby-sdl-2.1.2-r2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+
+inherit eutils ruby-ng
+
+RELEASE="rel-${PV//./-}"
+RUBY_S="rubysdl-${RELEASE}"
+
+DESCRIPTION="Ruby/SDL: Ruby bindings for SDL"
+HOMEPAGE="https://www.kmc.gr.jp/~ohai/rubysdl.en.html"
+SRC_URI="https://github.com/ohai/rubysdl/archive/${RELEASE}.tar.gz -> ${P}.tar.gz"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+
+IUSE="image mixer truetype mpeg sge"
+
+CDEPEND="
+ >=media-libs/libsdl-1.2.5
+ truetype? ( >=media-libs/sdl-ttf-2.0.6 )
+ image? ( >=media-libs/sdl-image-1.2.2 )
+ mixer? ( >=media-libs/sdl-mixer-1.2.4 )
+ mpeg? ( >=media-libs/smpeg-0.4.4-r1 )
+ sge? ( media-libs/sge )"
+DEPEND="${DEPEND} ${CDEPEND}"
+RDEPEND="${RDEPEND} ${CDEPEND}"
+
+each_ruby_configure() {
+ ${RUBY} extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ emake V=1 || die "emake failed"
+}
+
+each_ruby_install() {
+ emake V=1 DESTDIR="${D}" install || die "einstall failed"
+}
+
+all_ruby_install() {
+ dodoc README.en README.ja NEWS.en NEWS.ja
+ insinto /usr/share/doc/${P}/doc
+ doins doc-en/*
+ insinto /usr/share/doc/${P}/sample
+ doins sample/*
+}
+
+pkg_postinst () {
+ if ! use image || ! use mixer || ! use truetype || ! use mpeg || ! use sge; then
+ echo ""
+ ewarn "If any of the following packages are not installed, Ruby/SDL"
+ ewarn "will be missing some functionality. This is ok, but may"
+ ewarn "cause errors in Ruby/SDL programs that need these libraries:"
+ ewarn ""
+ ewarn "\tmedia-libs/sdl-image\tImage loading (PNG, JPEG, etc.)"
+ ewarn "\tmedia-libs/sdl-mixer\tSound mixing"
+ ewarn "\tmedia-libs/sdl-ttf\tTrueType Fonts"
+ ewarn "\tmedia-libs/sge\t\tVarious cool graphics extensions"
+ ewarn "\tmedia-libs/smpeg\tMPEG playback (including mp3)"
+ ewarn ""
+ ewarn "If you need the functionality offered by these libraries,"
+ ewarn "emerge the desired libraries, then re-emerge dev-ruby/rubysdl"
+ echo ""
+ fi
+}