summaryrefslogtreecommitdiff
path: root/dev-ruby/ruby-rsvg/ruby-rsvg-3.3.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
commit5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (patch)
tree66e860a5099bcad013f1cf667255dc372a7c11b3 /dev-ruby/ruby-rsvg/ruby-rsvg-3.3.2.ebuild
parent7218e1b46bceac05841e90472501742d905fb3fc (diff)
gentoo resync : 20.03.2021
Diffstat (limited to 'dev-ruby/ruby-rsvg/ruby-rsvg-3.3.2.ebuild')
-rw-r--r--dev-ruby/ruby-rsvg/ruby-rsvg-3.3.2.ebuild49
1 files changed, 0 insertions, 49 deletions
diff --git a/dev-ruby/ruby-rsvg/ruby-rsvg-3.3.2.ebuild b/dev-ruby/ruby-rsvg/ruby-rsvg-3.3.2.ebuild
deleted file mode 100644
index fb6f57589d74..000000000000
--- a/dev-ruby/ruby-rsvg/ruby-rsvg-3.3.2.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby23 ruby24 ruby25 ruby26"
-
-RUBY_FAKEGEM_NAME=rsvg2
-
-inherit ruby-ng-gnome2
-
-RUBY_S=ruby-gnome2-all-${PV}/rsvg2
-
-DESCRIPTION="Ruby bindings for librsvg"
-KEYWORDS="amd64 ~ppc ~x86"
-
-RDEPEND+=" >=gnome-base/librsvg-2.16.1"
-DEPEND+=" >=gnome-base/librsvg-2.16.1"
-
-ruby_add_rdepend "
- ~dev-ruby/ruby-cairo-gobject-${PV}
- ~dev-ruby/ruby-gdkpixbuf2-${PV}
-"
-
-all_ruby_prepare() {
- # Avoid unneeded dependency on test-unit-notify.
- sed -i -e '/notify/ s:^:#:' test/rsvg2-test-utils.rb || die
-
- # Avoid compilation of dependencies during test.
- sed -i -e '/and have_make/,/^ end/ s:^:#:' test/run-test.rb || die
-
- # Avoid test that fails and may be version-specific
- sed -i -e '/test_unlimited/aomit "version specific?"' test/test-handle.rb || die
-}
-
-each_ruby_configure() {
- :
-}
-
-each_ruby_compile() {
- :
-}
-
-each_ruby_install() {
- each_fakegem_install
-}
-
-each_ruby_test() {
- ${RUBY} test/run-test.rb || die
-}