summaryrefslogtreecommitdiff
path: root/dev-ruby/ruby-romkan
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/ruby-romkan
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/ruby-romkan')
-rw-r--r--dev-ruby/ruby-romkan/Manifest4
-rw-r--r--dev-ruby/ruby-romkan/files/ruby-romkan-ruby19.patch32
-rw-r--r--dev-ruby/ruby-romkan/metadata.xml12
-rw-r--r--dev-ruby/ruby-romkan/ruby-romkan-0.4-r6.ebuild31
4 files changed, 79 insertions, 0 deletions
diff --git a/dev-ruby/ruby-romkan/Manifest b/dev-ruby/ruby-romkan/Manifest
new file mode 100644
index 000000000000..bf2f90adb1c1
--- /dev/null
+++ b/dev-ruby/ruby-romkan/Manifest
@@ -0,0 +1,4 @@
+AUX ruby-romkan-ruby19.patch 900 BLAKE2B 209603b4b3ac92a7a076fa5c121d1274bc974dff581eb6d53b09163a555a4bd2ad2aead660c2e6066bf94b309f82927e88ffc1a856696d1c0f9852ae4dd3b7f5 SHA512 b031c67b6bc821ab6dfd91cafaf98384eca8b8ecbe7f8490e54c06ca54e817e07f54b8f97a0b9499b6fc617e4493a737bb06177d2ecddc97db435c2ab5259073
+DIST ruby-romkan-0.4.tar.gz 4653 BLAKE2B 2680fece04c80be9d2f312a98c5d5756fcd465aacbee5a3ddbd5409e89d8d54cbc0dd27b556173e94ead143dcc25cde530fb002dd3c4833d321b6169afaabaf7 SHA512 d4e4089122d643878a0e19852dd650c4d7e35918838edfe4bc210a5d26cc3e55b5be430db4378e75f44a3435331fd4e1155dfc3e1846babb3a1b626dd127eacd
+EBUILD ruby-romkan-0.4-r6.ebuild 691 BLAKE2B 032dedd01605bcf27e70dcecaef2b44bf76aaf28561b45ebf0fa77383ccc7e2147d47fb675096d6877c3981902b2ec71a125144eae76e50c55a1216f5b20dc92 SHA512 e62bf43b28f4d039e974c12916cb122bbf40480aa3964b66238ce07b2b0d414bfb072c87e079c21f1e16b692ebe94b5c4f504f3616f08f2e242cd8157dff491c
+MISC metadata.xml 338 BLAKE2B f8a954021951292146b75f8693ae3b4219f237f771a0d31e3f60ab9a58a9ca3324a751b864a90dfdca505ea41e30888f53f756cf109be467ce954fd77730e894 SHA512 4fad57cfae8fe4452b4ef063dac4700b42e391549ebbd37a6b9be5205d04f463b05f7e92520a50a5147da8a40dd61eb6780d2fdb851518cb1409ec4cd5afd76d
diff --git a/dev-ruby/ruby-romkan/files/ruby-romkan-ruby19.patch b/dev-ruby/ruby-romkan/files/ruby-romkan-ruby19.patch
new file mode 100644
index 000000000000..4ae355749281
--- /dev/null
+++ b/dev-ruby/ruby-romkan/files/ruby-romkan-ruby19.patch
@@ -0,0 +1,32 @@
+--- romkan.rb 2002-02-12 02:45:16.000000000 +0100
++++ romkan.rb 2012-06-25 10:15:59.723542130 +0200
+@@ -1,3 +1,4 @@
++# -*- encoding:euc-jp -*-
+ #
+ # Ruby/Romkan - a Romaji <-> Kana conversion library for Ruby.
+ #
+@@ -209,13 +210,13 @@
+ HEPPAT = HEPBURN.sort {|a, b| b.length <=> a.length }.join "|"
+
+ TO_HEPBURN = (romrom = Hash.new
+- KUNREI.each_with_index {|x, i|
+- romrom[KUNREI[i]] = HEPBURN[i]}
++ KUNREI.each_with_index {|x, j|
++ romrom[KUNREI[j]] = HEPBURN[j]}
+ romrom)
+
+ TO_KUNREI = (romrom = Hash.new
+- HEPBURN.each_with_index {|x, i|
+- romrom[HEPBURN[i]] = KUNREI[i]}
++ HEPBURN.each_with_index {|x, j|
++ romrom[HEPBURN[j]] = KUNREI[j]}
+ romrom)
+
+ # FIXME: ad hod solution
+--- test.rb 2002-02-12 02:45:25.000000000 +0100
++++ test.rb 2012-06-25 10:13:51.832021574 +0200
+@@ -1,3 +1,4 @@
++# -*- encoding:euc-jp -*-
+ #
+ # ruby -Ke test.rb </dev/null && echo ok
+ #
diff --git a/dev-ruby/ruby-romkan/metadata.xml b/dev-ruby/ruby-romkan/metadata.xml
new file mode 100644
index 000000000000..a51c24fcf9bb
--- /dev/null
+++ b/dev-ruby/ruby-romkan/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+</maintainer>
+<maintainer type="project">
+ <email>cjk@gentoo.org</email>
+ <name>Cjk</name>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-ruby/ruby-romkan/ruby-romkan-0.4-r6.ebuild b/dev-ruby/ruby-romkan/ruby-romkan-0.4-r6.ebuild
new file mode 100644
index 000000000000..b72b9d47a94b
--- /dev/null
+++ b/dev-ruby/ruby-romkan/ruby-romkan-0.4-r6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby22 ruby23 ruby24 ruby25"
+
+inherit ruby-ng
+
+DESCRIPTION="A Romaji <-> Kana conversion library for Ruby"
+HOMEPAGE="http://0xcc.net/ruby-romkan/"
+SRC_URI="http://0xcc.net/ruby-romkan/${P}.tar.gz"
+LICENSE="Ruby"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm ~hppa ia64 ~mips ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE=""
+
+DOCS="ChangeLog *.rd"
+
+RUBY_PATCHES=( "${FILESDIR}/${PN}-ruby19.patch" )
+
+each_ruby_test() {
+ ${RUBY} -I. -Ke test.rb < /dev/null || die "test failed"
+}
+
+each_ruby_install() {
+ doruby romkan.rb
+}
+
+all_ruby_install() {
+ dodoc ${DOCS}
+}