summaryrefslogtreecommitdiff
path: root/dev-ruby/ruby-progressbar
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-20 13:00:15 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-20 13:00:15 +0000
commite937ca8df21d3186f65edc11c872706c80eb8a61 (patch)
tree6758813cd0a8bd1da09045a9171ff389b1b39718 /dev-ruby/ruby-progressbar
parent1b5d79237a144dcb8753c783941843d879a906e2 (diff)
gentoo auto-resync : 20:03:2024 - 13:00:14
Diffstat (limited to 'dev-ruby/ruby-progressbar')
-rw-r--r--dev-ruby/ruby-progressbar/Manifest1
-rw-r--r--dev-ruby/ruby-progressbar/ruby-progressbar-1.13.0-r1.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-ruby/ruby-progressbar/Manifest b/dev-ruby/ruby-progressbar/Manifest
index 105cb23abe21..ceb171d270c3 100644
--- a/dev-ruby/ruby-progressbar/Manifest
+++ b/dev-ruby/ruby-progressbar/Manifest
@@ -1,3 +1,4 @@
DIST ruby-progressbar-1.13.0.tar.gz 67185 BLAKE2B 27ea25e4caeb70aefb2523a4f4399056bdb9973deb567fc80eb9daeab6193ecc3693c8364bb43fc94906e6b63a0db1ace6bbd9b00defa0e02177983371b54ad3 SHA512 64723422d6216f2640bc60c8068c8d0437fbc5f315343b13c3167130d868a0aa978f098554ace3ea71406688c0b3c0ed94296adc6b9229ea14df5dbcb56322a3
+EBUILD ruby-progressbar-1.13.0-r1.ebuild 931 BLAKE2B 777e8ae35d82bf513d812d895e9ec95dbd7a957d5cfe1a61df2faacc728bb3ab479f656ba8ea8cea5f1d8b931ee00e7733493f7d2c73af7e26cd5518eddd4b29 SHA512 580ffc343e67e1ab265e905bc35b110d85b01413fadc16e2ddfbe54d7a06630a2c0c1568ee2a4348f287aeb128e90fd7647545ccb9246e745d4a8a698d8b3f2f
EBUILD ruby-progressbar-1.13.0.ebuild 858 BLAKE2B 80aa1c556237e00e59fda8865d65b078b167900a187d31d612756d04dd35c734ec9ab6adf672251a661777c8e1ffc6f43e64278510d6d91419c1b90cb5aa6bdf SHA512 f1845190572b1119bd643111cd3f666c196d7745d39fa23627fcb3aa672d10f5d035cad1fcdb06e74abfd6e8449ceab88ea6acd7e4527855955825edee18a9d3
MISC metadata.xml 353 BLAKE2B 7805fc15a01ee29282bd6097c97659acdd06e1437042d9ff67f2eec8fa0800361e143741cb28436a890ab4952777587e8058c5a6c40d6d6100d5aad7e47f160d SHA512 b98e1e7fae3dd752ec27801aec152ec007d11cec4bdbd125b906ef42797052a5f7ab1dc8e718f133243a309a4aba267d4bc0caba41701b25bab13bb4442f4f7e
diff --git a/dev-ruby/ruby-progressbar/ruby-progressbar-1.13.0-r1.ebuild b/dev-ruby/ruby-progressbar/ruby-progressbar-1.13.0-r1.ebuild
new file mode 100644
index 000000000000..b8659a7f3211
--- /dev/null
+++ b/dev-ruby/ruby-progressbar/ruby-progressbar-1.13.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_RUBY="ruby31 ruby32 ruby33"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_GEMSPEC="ruby-progressbar.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Text Progress Bar Library for Ruby"
+HOMEPAGE="https://github.com/jfelchner/ruby-progressbar"
+SRC_URI="https://github.com/jfelchner/ruby-progressbar/archive/releases/v${PV}.tar.gz -> ${P}.tar.gz"
+RUBY_S="ruby-progressbar-releases-v${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+
+ruby_add_bdepend "test? ( dev-ruby/timecop )"
+
+all_ruby_prepare() {
+ sed -e '/warning_filter/ s:^:#:' \
+ -e '/rspectacular/arequire "ruby-progressbar"; require "timecop"' \
+ -e '/rspectacular/ s:^:#:' \
+ -i spec/spec_helper.rb || die
+}