summaryrefslogtreecommitdiff
path: root/dev-ruby/ruby-progressbar
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
commit43793fab84041cfc5c60c0151d1591b8a69fb24a (patch)
tree6208a7f4fc744684fce0f55acbb47511acace498 /dev-ruby/ruby-progressbar
parent28e3d252dc8ac8a5635206dfefe1cfe05058d1db (diff)
gentoo resync : 25.08.2018
Diffstat (limited to 'dev-ruby/ruby-progressbar')
-rw-r--r--dev-ruby/ruby-progressbar/Manifest2
-rw-r--r--dev-ruby/ruby-progressbar/ruby-progressbar-1.10.0.ebuild35
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-ruby/ruby-progressbar/Manifest b/dev-ruby/ruby-progressbar/Manifest
index b574383f84f3..60d1899730ec 100644
--- a/dev-ruby/ruby-progressbar/Manifest
+++ b/dev-ruby/ruby-progressbar/Manifest
@@ -1,5 +1,7 @@
+DIST ruby-progressbar-1.10.0.tar.gz 51483 BLAKE2B 24b92718fe933caa29460939a816b14a492d3144e9a891839ec3b5dbac103849bc0aa3becfb47e507a001ce6b0d0bbf2e0b207fe8d7cb51443924e81c9395b0a SHA512 ec645858d619a95081304905661918eef6d5bd19c0f8d00beac48df3f202d18ac85811d51028d71ab144a5a56649feb2409eca59b3db26733c00a1a54a7ef55d
DIST ruby-progressbar-1.4.2.gem 24064 BLAKE2B 4c26f5c281129a7333c8a7a1f7738a094ec02d769293252c8fbc6df0bea99971cd0d235b6bbeba7e2e4fac10409028f7cdb15870484878c26d9ea9f709f0135b SHA512 443fc015b2dcabc76c685f1529a39ffba289cb00c3cee3992ef240fb9822729f9049db4d85c58ee1ab6cc17927cb325044ea45a968c755a9b5ad93f7b9999fbd
DIST ruby-progressbar-1.9.0.tar.gz 47888 BLAKE2B 26707f4f931e378da18a29d20da47963c06bde537155d0e9bd3a623b9b3edd9d653a50ca106dcb29ffb53668a869815818398ae514ef3302465cf5a5504b2cda SHA512 d2b01c205dec3bad6989a1ea466070fdc0c3fc5bc0c8685a21094c52d2f2c6a11849b42d88d3ec70df1475ad47c9f84a4c4b603948344643310e2180122d9b67
+EBUILD ruby-progressbar-1.10.0.ebuild 1032 BLAKE2B 4232d3368457607a33731f9711161b08e7e5e1f846b0f034bd19363cd1d5085cc52f4f9307ce6fe148f8dfb95cc13288064a5e42ff2001b0144d60a0aa42eee9 SHA512 9402021f21d8d8d47cbcfe38228ba5cd75061e5eb22367bfc44440fd2f5983e8aa36e81679cb672b17b0b5aba9f637884f2f07db27633d7b16e4230b9e410aa1
EBUILD ruby-progressbar-1.4.2-r1.ebuild 586 BLAKE2B d9a86d4032d44252d30e5fcb3774ec26efbfb6d1348cc604fc6008ab31ef836e84e558bdf1610168ac97e06aa48310f7d1b74e908e5e3aee60ef165b946b8535 SHA512 7fe1ac90518b66e1605b96c966e31ac111491d1af807b9f5d45a27832d872452db3a1c3aa981af03247670139a3feaf7d26f3443b32f6aafaf05cfd8407a7c22
EBUILD ruby-progressbar-1.9.0.ebuild 1032 BLAKE2B 4232d3368457607a33731f9711161b08e7e5e1f846b0f034bd19363cd1d5085cc52f4f9307ce6fe148f8dfb95cc13288064a5e42ff2001b0144d60a0aa42eee9 SHA512 9402021f21d8d8d47cbcfe38228ba5cd75061e5eb22367bfc44440fd2f5983e8aa36e81679cb672b17b0b5aba9f637884f2f07db27633d7b16e4230b9e410aa1
MISC metadata.xml 352 BLAKE2B a36b436c51b56ed96a170c6edaff16655ff0d3b42f2cc6b13e67c252f89e2d56c47ce0c69fd693acc9ddab9a755a5fbf5d72e360f2e6a16bc0117148eb7a25ef SHA512 a572b7825c4e778c503bfa3bb1b82d4d91c28285578c614a8a0c62bdf1967f307645c92f0101a4898baa0ebeac9a26455e459b2440db6989593c0cc4472df616
diff --git a/dev-ruby/ruby-progressbar/ruby-progressbar-1.10.0.ebuild b/dev-ruby/ruby-progressbar/ruby-progressbar-1.10.0.ebuild
new file mode 100644
index 000000000000..033082b7ba8b
--- /dev/null
+++ b/dev-ruby/ruby-progressbar/ruby-progressbar-1.10.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Text Progress Bar Library for Ruby"
+HOMEPAGE="https://github.com/jfelchner/ruby-progressbar"
+SRC_URI="https://github.com/jfelchner/ruby-progressbar/archive/releases/v${PV}.tar.gz -> ${P}.tar.gz"
+RUBY_S="ruby-progressbar-releases-v${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+IUSE="test"
+
+ruby_add_bdepend "test? ( dev-ruby/rspectacular dev-ruby/timecop )"
+
+all_ruby_prepare() {
+ sed -i -e '/warning_filter/ s:^:#:' \
+ spec/spec_helper.rb || die
+ # Avoid ruby24 syntax for an unneeded check
+ sed -i -e '/^return/ s:^:#:' spec/ruby-progressbar/refinements/enumerator_spec.rb || die
+}