summaryrefslogtreecommitdiff
path: root/dev-ruby/ruby-progressbar
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-02 21:45:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-02 21:45:28 +0100
commit2018227e9344edb9da15fc6a4a8298086cc2aa77 (patch)
treec18e1c09e605e94e2a1e93345ad25746cc9e14b9 /dev-ruby/ruby-progressbar
parent6f8038813c460b4f0572d5ef595cdfa94af3a94d (diff)
gentoo resync : 02.06.2019
Diffstat (limited to 'dev-ruby/ruby-progressbar')
-rw-r--r--dev-ruby/ruby-progressbar/Manifest2
-rw-r--r--dev-ruby/ruby-progressbar/ruby-progressbar-1.10.1.ebuild35
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-ruby/ruby-progressbar/Manifest b/dev-ruby/ruby-progressbar/Manifest
index 03f3b0aeb223..8ae9e80ff216 100644
--- a/dev-ruby/ruby-progressbar/Manifest
+++ b/dev-ruby/ruby-progressbar/Manifest
@@ -1,5 +1,7 @@
DIST ruby-progressbar-1.10.0.tar.gz 51483 BLAKE2B 24b92718fe933caa29460939a816b14a492d3144e9a891839ec3b5dbac103849bc0aa3becfb47e507a001ce6b0d0bbf2e0b207fe8d7cb51443924e81c9395b0a SHA512 ec645858d619a95081304905661918eef6d5bd19c0f8d00beac48df3f202d18ac85811d51028d71ab144a5a56649feb2409eca59b3db26733c00a1a54a7ef55d
+DIST ruby-progressbar-1.10.1.tar.gz 53416 BLAKE2B ee435291cd55558843ab05254c01a6148711aee54a5ce80d7b03902e32fd8735fda2e3686794f3f2c8a62c7ca26d90df4d63b48c8d947a471279c35131c49898 SHA512 6cbd791833a1638949c7283b5c475164b44ec8a5d4c7eb417d741da5c9cda9e777481a785f112be7fd1c3714668ad58cbf9aa39eecb61d1022fb3bb35ddb6203
DIST ruby-progressbar-1.4.2.gem 24064 BLAKE2B 4c26f5c281129a7333c8a7a1f7738a094ec02d769293252c8fbc6df0bea99971cd0d235b6bbeba7e2e4fac10409028f7cdb15870484878c26d9ea9f709f0135b SHA512 443fc015b2dcabc76c685f1529a39ffba289cb00c3cee3992ef240fb9822729f9049db4d85c58ee1ab6cc17927cb325044ea45a968c755a9b5ad93f7b9999fbd
EBUILD ruby-progressbar-1.10.0.ebuild 1036 BLAKE2B cc1a671361c75ec7c53d71be60216423c00ebb065ec8cd7761508bb3b3ff289afa0a7a4328a9e1bc2c0c4a9ed7ef8d2ffa934640bc0835394b6b1b2ff43f2ba8 SHA512 1fc42617574876ffa95a44c353b29e54425f3cb7c5d85e5edaf54d96b1be87434b72006164768b05b85071893f4ada4028c98691aed89be2c9f0cd1c87b4df5e
+EBUILD ruby-progressbar-1.10.1.ebuild 1029 BLAKE2B 24093411f6bdcf8e8cd93761d889682edcd462d898b558b656a4536f0420f3c89f14c67ce118f64511cd930fe378cca809a872a785274794eada2a07afe1cdb6 SHA512 82a8e0d8e9b0641a832d4b2a1f77d73e88178580729fc897b5c6cb69b140eacee5c862980575cf97cb1e8f647902e9870d0bb06ada04f7a84d1d077656cc1a74
EBUILD ruby-progressbar-1.4.2-r1.ebuild 586 BLAKE2B d9a86d4032d44252d30e5fcb3774ec26efbfb6d1348cc604fc6008ab31ef836e84e558bdf1610168ac97e06aa48310f7d1b74e908e5e3aee60ef165b946b8535 SHA512 7fe1ac90518b66e1605b96c966e31ac111491d1af807b9f5d45a27832d872452db3a1c3aa981af03247670139a3feaf7d26f3443b32f6aafaf05cfd8407a7c22
MISC metadata.xml 352 BLAKE2B a36b436c51b56ed96a170c6edaff16655ff0d3b42f2cc6b13e67c252f89e2d56c47ce0c69fd693acc9ddab9a755a5fbf5d72e360f2e6a16bc0117148eb7a25ef SHA512 a572b7825c4e778c503bfa3bb1b82d4d91c28285578c614a8a0c62bdf1967f307645c92f0101a4898baa0ebeac9a26455e459b2440db6989593c0cc4472df616
diff --git a/dev-ruby/ruby-progressbar/ruby-progressbar-1.10.1.ebuild b/dev-ruby/ruby-progressbar/ruby-progressbar-1.10.1.ebuild
new file mode 100644
index 000000000000..0910ef551afc
--- /dev/null
+++ b/dev-ruby/ruby-progressbar/ruby-progressbar-1.10.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Text Progress Bar Library for Ruby"
+HOMEPAGE="https://github.com/jfelchner/ruby-progressbar"
+SRC_URI="https://github.com/jfelchner/ruby-progressbar/archive/releases/v${PV}.tar.gz -> ${P}.tar.gz"
+RUBY_S="ruby-progressbar-releases-v${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+IUSE="test"
+
+ruby_add_bdepend "test? ( dev-ruby/rspectacular dev-ruby/timecop )"
+
+all_ruby_prepare() {
+ sed -i -e '/warning_filter/ s:^:#:' \
+ spec/spec_helper.rb || die
+ # Avoid ruby24 syntax for an unneeded check
+ sed -i -e '/^return/ s:^:#:' spec/ruby-progressbar/refinements/enumerator_spec.rb || die
+}