summaryrefslogtreecommitdiff
path: root/dev-ruby/ruby-prof
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-11-03 06:47:15 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-11-03 06:47:15 +0000
commitfc2f1018fc323ef2c6572734a9b130427cba76a6 (patch)
treef834bdc9a67923ce75297c09d00d1e7b90791d26 /dev-ruby/ruby-prof
parent162945d2a91899b637bbb9e163b406350de12906 (diff)
gentoo resync : 03.11.2021
Diffstat (limited to 'dev-ruby/ruby-prof')
-rw-r--r--dev-ruby/ruby-prof/Manifest2
-rw-r--r--dev-ruby/ruby-prof/ruby-prof-1.4.2.ebuild51
2 files changed, 0 insertions, 53 deletions
diff --git a/dev-ruby/ruby-prof/Manifest b/dev-ruby/ruby-prof/Manifest
index a549cb325575..cab91b02e61d 100644
--- a/dev-ruby/ruby-prof/Manifest
+++ b/dev-ruby/ruby-prof/Manifest
@@ -1,5 +1,3 @@
-DIST ruby-prof-1.4.2.tgz 90386 BLAKE2B 55263f6cd24b18112a917c2b03a57ca91619419244f79b2b06f6d6794f76d9411d4e1b39dbb2e4b7e2ca6cc03b244f529f4b56fec54ef5fda18853ec2ef05fb4 SHA512 e75a8898533dd2ce9098fcf940883e3cbeaeaecdaebe3592ee67321feb4e294e25bdf14ce6cac50fb6d582cd55d33f175929a1d5446a21b74eb86c468e779fc3
DIST ruby-prof-1.4.3.tgz 232032 BLAKE2B 68df149718869afac89b2240263cd3dd48c28b592f32cd7bc8a918b67de7a10abc3a1af04cb00eeaec9e6f7292e5258d22ba8bec0243361289add943535ffe39 SHA512 fd19d97b88b52c07331bf885c69215267eccb3a0519eb3bb6cd6e5907af55ebbace32f3bdef5b1f340bc3c4779666d7f4100878e647fdfde4da3a4df2a946ebe
-EBUILD ruby-prof-1.4.2.ebuild 1336 BLAKE2B 244a6ec8cf01fd2726f6c7b5d6f0bbf379b63aae51b576bee68d7bfaf753bbb2070425c5640550f4be27041207305be0a544efbedb90b7bb7b194dae21daa77c SHA512 4367d812a86f884fb2822d1f140746b8773f67cc7ba8f4863edd605a9ec90d454e1849074f36fd09fc8484d90beff228785c9a04670d2784e15dc41abb9114b5
EBUILD ruby-prof-1.4.3.ebuild 1143 BLAKE2B 9237d1ef512057ab6f3bdc569de1f414644bf13d379c26cab84cea50a22f6d4a17ae84e6ae19bf4ddd15268a40a92c88a6b77271cbaeeb775c22be5982e6e43c SHA512 1fb62f262b0f07043a8364e7adf851f7309dbd04b855d62d4bbb7a6742d9e116fd4851e635e1f7abd63fa6a1a902ec7738ac61dfef33405a5b2a1b28dac343a2
MISC metadata.xml 346 BLAKE2B 245dc508fb9933ff6a69b4e7c8a516ac9bb237798680ae70a8fbaeb57481520760f5a17a62cb045f82a955e0fc882fd84fb60d17b68bec1180b386355ca6b6fd SHA512 2cb1d6e31ac399f7faceccfd9dcc5e1a1e29bc10596ba3e0b3960ecc2bc215b21d351611e3ab6bfe7451fcee3bd4880a229b8266b7c8f6321bc79bdd5109b5d9
diff --git a/dev-ruby/ruby-prof/ruby-prof-1.4.2.ebuild b/dev-ruby/ruby-prof/ruby-prof-1.4.2.ebuild
deleted file mode 100644
index 716e4bf8ce7a..000000000000
--- a/dev-ruby/ruby-prof/ruby-prof-1.4.2.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-USE_RUBY="ruby25 ruby26 ruby27"
-
-RUBY_FAKEGEM_EXTRADOC="README.rdoc CHANGES"
-RUBY_FAKEGEM_DOCDIR="doc"
-
-RUBY_FAKEGEM_GEMSPEC="ruby-prof.gemspec"
-
-inherit multilib ruby-fakegem
-
-DESCRIPTION="A module for profiling Ruby code"
-HOMEPAGE="https://github.com/ruby-prof/ruby-prof"
-SRC_URI="https://github.com/ruby-prof/${PN}/archive/${PV}.tar.gz -> ${P}.tgz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~x86"
-IUSE=""
-
-ruby_add_bdepend "test? ( dev-ruby/test-unit:2 dev-ruby/minitest )"
-
-all_ruby_prepare() {
- # Avoid bundler
- sed -i -e '/bundler/I s:^:#:' -e '/:build/ s:^:#:' Rakefile || die
-
- sed -i -e '2igem "test-unit"' -e '/bundler/ s:^:#:' test/test_helper.rb || die
-
- # We install the shared object in lib, not ext.
- sed -i -e 's#../ext/ruby_prof#../lib/ruby_prof#' lib/ruby-prof.rb || die
-
- # Avoid unneeded dependency on rake-compiler
- sed -i -e '/extensiontask/ s:^:#:' \
- -e '/ExtensionTask/,/end/ s:^:#:' Rakefile || die
-
- # Create directory required for the test suite to pass
- mkdir tmp || die
-}
-
-each_ruby_configure() {
- ${RUBY} -Cext/ruby_prof extconf.rb || die "extconf.rb failed"
-}
-
-each_ruby_compile() {
- emake V=1 -Cext/ruby_prof
-
- cp ext/ruby_prof/*$(get_modname) lib/ || die "copy of extension failed"
-}