summaryrefslogtreecommitdiff
path: root/dev-ruby/ruby-prof
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ruby/ruby-prof
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ruby/ruby-prof')
-rw-r--r--dev-ruby/ruby-prof/Manifest5
-rw-r--r--dev-ruby/ruby-prof/metadata.xml11
-rw-r--r--dev-ruby/ruby-prof/ruby-prof-0.16.2.ebuild62
3 files changed, 78 insertions, 0 deletions
diff --git a/dev-ruby/ruby-prof/Manifest b/dev-ruby/ruby-prof/Manifest
new file mode 100644
index 000000000000..5d39af57e518
--- /dev/null
+++ b/dev-ruby/ruby-prof/Manifest
@@ -0,0 +1,5 @@
+DIST ruby-prof-0.16.2.tgz 87039 SHA256 10bc9007ace7ec1444a12a4b47708cd790f9274dbdb229b0fe4fdd8d36267e25 SHA512 4a070486375a40afd03c006385a14f5d2ae3670a658e1153b086d0e63eb7a87af38ae060c9d457cd67a5e084f75dd997cd39b890ef4a510bbae801838f74f7f8 WHIRLPOOL 54196ef9a9c9c8d17cbcaa08aae89f20365645f1c21e2700ca6b7b3fd4aa46dcf9af1cbc654388c5e75f6312e59ef8814ce241d2081f55e399c4bb4c38051fe5
+EBUILD ruby-prof-0.16.2.ebuild 1590 SHA256 f6eed61ea5886562f690b63b344a7415ea5082c0412332d8e068475ee0f53c0b SHA512 376ffdeddc9bb37f668513e597a0a56a3c1d5beb9ebc6fba4fbff2dcff9be1b4815145bb08847e52c068b1f02a198c2e324ca20c5339c6e21ad695f09a968786 WHIRLPOOL 9ffabcf0327327e18a68dacf4b2ca12c52121b63d46335353361caa7b38e0780e4781ae66198be7afaf4cc4af4f0218b34602abb1e0ea80062c63ab21e551791
+MISC ChangeLog 3183 SHA256 6d2b7fa07abe2ac54e730a7019fe7c282c61bee2d505e691fdbc121548c14b99 SHA512 943a7d6101e7830d6c73c2925c3b928adeff5a31a0d01d93ec7d681996145636cda5508d03a473738955fbcf02ab0974392a3e7c6b8741e48c2bfad4d51a3702 WHIRLPOOL 448f5526a0470f61a8226f1cd6f1dca822ce997289b7d5b54eeaacd54e1b31a15776296718124f9d32e19d4452977d180acc8360f13bb5ac6515340f574ff232
+MISC ChangeLog-2015 6663 SHA256 009befc2c8f24c002268b582668b43fef6d516f236bd1951fcc80aae2d2f8395 SHA512 573a6429c5ed93c2d7baaf110b2c6d93ae12a9e902e44a4c9b8246637ad37c563be15ab01071355d275ba129bc7e38258452ab72facb9b46c5e30743c90a14a0 WHIRLPOOL db95fe26224a7dba13be972bfcf1585f75cd98027eba9a8bbd8539a04d2f7cbb494b2a0d0f6cd27d270a1b62b3f39ae92fb30be9603368b880105eee317f8e0e
+MISC metadata.xml 345 SHA256 c722be1bd806853e222d3fc7ade74378fdd904a63fb56a8bfbcf67045f1827bf SHA512 e1647ce0131d640e8de67cdaf4bedd36d5cf3cc1d251e08b3f36a7c82bf356f80a3911984adbe14d25250b2f5c3333a988b5baed8978adea0b68594d985f22ef WHIRLPOOL cfcbdc2222162ba8c8a80f9a6ff4422b394fc6104b88b6bbc988aed05389965211c112e8f32c52269bcc3c7fd34060410e01ba80d38a0b01a98f06c421ec7477
diff --git a/dev-ruby/ruby-prof/metadata.xml b/dev-ruby/ruby-prof/metadata.xml
new file mode 100644
index 000000000000..5753dc09dfba
--- /dev/null
+++ b/dev-ruby/ruby-prof/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ruby-prof/ruby-prof</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/ruby-prof/ruby-prof-0.16.2.ebuild b/dev-ruby/ruby-prof/ruby-prof-0.16.2.ebuild
new file mode 100644
index 000000000000..65a6ba3cbdaa
--- /dev/null
+++ b/dev-ruby/ruby-prof/ruby-prof-0.16.2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc CHANGES"
+RUBY_FAKEGEM_DOCDIR="doc"
+
+inherit multilib ruby-fakegem
+
+DESCRIPTION="A module for profiling Ruby code"
+HOMEPAGE="https://github.com/ruby-prof/ruby-prof"
+SRC_URI="https://github.com/ruby-prof/${PN}/archive/v${PV}.tar.gz -> ${P}.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/test-unit:2 dev-ruby/minitest )"
+
+all_ruby_prepare() {
+ # Avoid bundler
+ sed -i -e '/bundler/I s:^:#:' -e '/:build/ s:^:#:' Rakefile || die
+
+ sed -i -e '2igem "test-unit"' test/test_helper.rb || die
+
+ # Fix a timing-dependant spec since its thresholds for success are
+ # too tight.
+ sed -i -e '/test_class_methods/,/^ end/ s:^:#:' test/measure_cpu_time_test.rb || die
+
+ # We install the shared object in lib, not ext.
+ sed -i -e 's#../ext/ruby_prof#../lib/ruby_prof#' lib/ruby-prof.rb || die
+
+ # Avoid unneeded dependency on rake-compiler
+ sed -i -e '/extensiontask/ s:^:#:' \
+ -e '/ExtensionTask/,/end/ s:^:#:' Rakefile || die
+
+ # Create directory required for the test suite to pass
+ mkdir tmp || die
+}
+
+each_ruby_configure() {
+ ${RUBY} -Cext/ruby_prof extconf.rb || die "extconf.rb failed"
+}
+
+each_ruby_compile() {
+ emake V=1 -Cext/ruby_prof || die "build failed"
+
+ cp ext/ruby_prof/*$(get_modname) lib/ || die "copy of extension failed"
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ for dir in examples ; do
+ docinto "$dir"
+ dodoc -r "$dir"/*
+ done
+}