summaryrefslogtreecommitdiff
path: root/dev-ruby/ruby-pango/ruby-pango-3.3.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-08 01:07:24 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-08 01:07:24 +0100
commite3cf2c86fca1750343c1885311f857f185ee4f2d (patch)
treed9d1fbc20509d4c90f57fb2d9e1459bc8034c831 /dev-ruby/ruby-pango/ruby-pango-3.3.7.ebuild
parentf1af93971b7490792d8541bc790e0d8c6d787059 (diff)
gentoo resync : 08.09.2019
Diffstat (limited to 'dev-ruby/ruby-pango/ruby-pango-3.3.7.ebuild')
-rw-r--r--dev-ruby/ruby-pango/ruby-pango-3.3.7.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/ruby-pango/ruby-pango-3.3.7.ebuild b/dev-ruby/ruby-pango/ruby-pango-3.3.7.ebuild
new file mode 100644
index 000000000000..880b50d9aa51
--- /dev/null
+++ b/dev-ruby/ruby-pango/ruby-pango-3.3.7.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24 ruby25 ruby26"
+
+inherit ruby-ng-gnome2
+
+DESCRIPTION="Ruby Pango bindings"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+DEPEND+=" >=x11-libs/pango-1.2.1"
+RDEPEND+=" >=x11-libs/pango-1.2.1"
+
+ruby_add_rdepend "
+ ~dev-ruby/ruby-cairo-gobject-${PV}
+ ~dev-ruby/ruby-gobject-introspection-${PV}
+"
+
+all_ruby_prepare() {
+ # Remove test depending on specific locales to be set up: bug 526248
+ rm -f test/test-language.rb || die
+
+ # Avoid native installer
+ sed -i -e '/native-package-installer/ s:^:#: ; /^\s*setup_homebrew/ s:^:#:' ../glib2/lib/mkmf-gnome2.rb || die
+
+ # Avoid compilation of dependencies during test.
+ sed -i -e '/system/,/^ end/ s:^:#:' test/run-test.rb || die
+}
+
+each_ruby_test() {
+ # Include pango path since run-test does not list it
+ ${RUBY} -Iext/pango test/run-test.rb || die
+}