summaryrefslogtreecommitdiff
path: root/dev-ruby/ruby-pango/ruby-pango-3.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ruby/ruby-pango/ruby-pango-3.1.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ruby/ruby-pango/ruby-pango-3.1.1.ebuild')
-rw-r--r--dev-ruby/ruby-pango/ruby-pango-3.1.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/ruby-pango/ruby-pango-3.1.1.ebuild b/dev-ruby/ruby-pango/ruby-pango-3.1.1.ebuild
new file mode 100644
index 000000000000..c6f989568ce5
--- /dev/null
+++ b/dev-ruby/ruby-pango/ruby-pango-3.1.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+inherit ruby-ng-gnome2
+
+DESCRIPTION="Ruby Pango bindings"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+DEPEND+=" >=x11-libs/pango-1.2.1"
+RDEPEND+=" >=x11-libs/pango-1.2.1"
+
+ruby_add_rdepend ">=dev-ruby/ruby-glib2-${PV}
+ >=dev-ruby/rcairo-1.14.0"
+ruby_add_bdepend ">=dev-ruby/rcairo-1.14.0"
+
+all_ruby_prepare() {
+ # Remove test depending on specific locales to be set up: bug 526248
+ rm -f test/test-language.rb || die
+
+ # Avoid compilation of dependencies during test.
+ sed -i -e '/system/,/^ end/ s:^:#:' test/run-test.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} test/run-test.rb || die
+}