summaryrefslogtreecommitdiff
path: root/dev-ruby/ruby-ldap
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-21 10:04:00 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-21 10:04:00 +0100
commit7c334a9594ae315e537bf98259b95bafc60d479c (patch)
treefc41ac024e70df2bad3160b2d02fd5a01adde46b /dev-ruby/ruby-ldap
parentd1849ceeb9c09150c11cc0d112883cfba503af27 (diff)
gentoo auto-resync : 21:07:2023 - 10:04:00
Diffstat (limited to 'dev-ruby/ruby-ldap')
-rw-r--r--dev-ruby/ruby-ldap/Manifest2
-rw-r--r--dev-ruby/ruby-ldap/files/ruby-ldap-0.9.20-clang16-fix.patch12
-rw-r--r--dev-ruby/ruby-ldap/ruby-ldap-0.9.20-r4.ebuild38
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-ruby/ruby-ldap/Manifest b/dev-ruby/ruby-ldap/Manifest
index 760ed032f2b9..f076dcdb885b 100644
--- a/dev-ruby/ruby-ldap/Manifest
+++ b/dev-ruby/ruby-ldap/Manifest
@@ -1,3 +1,5 @@
+AUX ruby-ldap-0.9.20-clang16-fix.patch 368 BLAKE2B 30c359696d8db213b2fe9b6f4f32d8b6583b7141ecc95e56e97cb736eac31218da6d0298c5810b39bc4110b22c90cc04993f5de3f1f7908bf9291011b3ecb348 SHA512 67675d6f045be53aeee10eaa9635b9d92dd6819234da4561ce0bc89ed79bad8ac1382fa8553fdb666a92bf4ea0b26c15c8f7b81ccfdd574a6ad38627f35097ea
DIST ruby-ldap-0.9.20.gem 67072 BLAKE2B 626a35ab764dacfb37c727d867e1d435222730a3e7ea745ee4e7ec051ce3a822cc5a1230b463bc12f4a2390db667ed3b61deceb9842c014f64cdf43a26d285f9 SHA512 4f4902e7eaf4fe0cd421d58c73ce4e625d61ee20ef02363d3cf5754c66237e0f378ac433b234c2b86d5f5284ae03b7ae6c46d3575c512487bc1a931d021c9517
EBUILD ruby-ldap-0.9.20-r3.ebuild 924 BLAKE2B 2d1d6de133628c3be046ae146f8a3d43a43d0df3c560558b1780d85a686d8c949948e6ce19d95533207143daed0a4435008f5189834bfa81ee5c0d4b195b9b98 SHA512 abbb5b84f7e6ba20ff06999f996c2230f7971624f4923229db59c173a2808a029bbe38be7d5dea1f393f7ea00e61c7b0d04832c12fe44045f9ae6e290a43faf5
+EBUILD ruby-ldap-0.9.20-r4.ebuild 985 BLAKE2B aee2235f42612113704fec3b917fdb79cbb89d993e2d1e22bd1dff9c74391799ac620ae1a98c7780c7623ac253b3fc204e5c9045a096b522881b6ee3720446ac SHA512 62c82db2a3d7efdb74149a43eb26b649b355306f0593184bb5d765e4f234d35702d486ce1dc13418d2a9689daee1d1c85b5c49931684e55fbc99e4738283acaf
MISC metadata.xml 391 BLAKE2B c7512c86b40f4a8cd418e12633883da21a0ad0d9de73d05307f5f2b0fc2aca31b9835cd709f5f0a52b487cf7197253a3a2b579d38ff44c91ae50d8469ac3716c SHA512 763bd735ebffb233f9a66e77754de2092c868585565a2c0e770f9e8909d0bf7e3bc312658f6d6d0f124e93c45e06ea9bbd864137ad5d7a1e3979f56e24713180
diff --git a/dev-ruby/ruby-ldap/files/ruby-ldap-0.9.20-clang16-fix.patch b/dev-ruby/ruby-ldap/files/ruby-ldap-0.9.20-clang16-fix.patch
new file mode 100644
index 000000000000..580584c61994
--- /dev/null
+++ b/dev-ruby/ruby-ldap/files/ruby-ldap-0.9.20-clang16-fix.patch
@@ -0,0 +1,12 @@
+Bug: https://bugs.gentoo.org/884405
+--- a/ldap.c
++++ b/ldap.c
+@@ -201,7 +201,7 @@ rb_ldap_hash2mods (VALUE self, VALUE op, VALUE hash)
+ VALUE tmp;
+
+ tmp = rb_assoc_new (op, rb_ary_new ());
+- rb_iterate (rb_each, hash, rb_ldap_hash2mods_i, tmp);
++ rb_iterate (rb_each, hash, (rb_block_call_func_t)rb_ldap_hash2mods_i, tmp);
+
+ return rb_ary_entry (tmp, 1);
+ }
diff --git a/dev-ruby/ruby-ldap/ruby-ldap-0.9.20-r4.ebuild b/dev-ruby/ruby-ldap/ruby-ldap-0.9.20-r4.ebuild
new file mode 100644
index 000000000000..117ecd8ad824
--- /dev/null
+++ b/dev-ruby/ruby-ldap/ruby-ldap-0.9.20-r4.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30 ruby31"
+
+inherit ruby-fakegem
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_EXTENSIONS=(./extconf.rb)
+RUBY_FAKEGEM_EXTRADOC="ChangeLog FAQ NOTES README TODO"
+
+DESCRIPTION="A Ruby interface to some LDAP libraries"
+HOMEPAGE="https://github.com/bearded/ruby-ldap"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="ssl"
+DEPEND=">=net-nds/openldap-2:=
+ dev-libs/cyrus-sasl
+ ssl? ( dev-libs/openssl:0= )"
+RDEPEND="${DEPEND}"
+
+# Current test set is interactive due to certificate generation and requires
+# running LDAP daemon
+RESTRICT="test"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.9.20-clang16-fix.patch
+)
+
+each_ruby_configure() {
+ local myconf="--with-openldap2"
+ if ! use ssl ; then
+ myconf="${myconf} --without-libcrypto --without-libssl"
+ fi
+ RUBY_FAKEGEM_EXTENSION_OPTIONS=${myconf} each_fakegem_configure
+}