summaryrefslogtreecommitdiff
path: root/dev-ruby/ruby-ldap
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:18:26 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:18:26 +0100
commit6c30cc2d5bd48ddbdbe8d75544899cd5dbfcaba4 (patch)
tree6ef7f6e1d48141a5da904d788b906da5bba4b697 /dev-ruby/ruby-ldap
parent62f82c107c3904ac6917ece47301d2999c7dd90e (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/ruby-ldap')
-rw-r--r--dev-ruby/ruby-ldap/Manifest2
-rw-r--r--dev-ruby/ruby-ldap/ruby-ldap-0.9.20.ebuild41
2 files changed, 43 insertions, 0 deletions
diff --git a/dev-ruby/ruby-ldap/Manifest b/dev-ruby/ruby-ldap/Manifest
index a6ef9b156909..d2b58d9248a6 100644
--- a/dev-ruby/ruby-ldap/Manifest
+++ b/dev-ruby/ruby-ldap/Manifest
@@ -1,3 +1,5 @@
DIST ruby-ldap-0.9.19.gem 91648 BLAKE2B 0ea6fe17ac2e4cd34a0834c6b95b1db4905e709010962959735cc3cedf9d50695d642b6042711b4f5154198fbe0bb5312903169ba8f1a7868b6f18d681a81682 SHA512 0ed931552df00c11855297ab44fd1c9a79e751937758d38189147f1d37cbce9b1da6fa42e64a9fd44610e948b1c13031013b7931ed473cd55b8425e64a50584a
+DIST ruby-ldap-0.9.20.gem 67072 BLAKE2B 626a35ab764dacfb37c727d867e1d435222730a3e7ea745ee4e7ec051ce3a822cc5a1230b463bc12f4a2390db667ed3b61deceb9842c014f64cdf43a26d285f9 SHA512 4f4902e7eaf4fe0cd421d58c73ce4e625d61ee20ef02363d3cf5754c66237e0f378ac433b234c2b86d5f5284ae03b7ae6c46d3575c512487bc1a931d021c9517
EBUILD ruby-ldap-0.9.19.ebuild 1096 BLAKE2B bf80a0140c10753cc1477c323b6280c3549e7d54cfb18a442d74fe47d16a9e3c2bb9936b1c11abc4069a5b982437ebcc979a3831667710942211da2f8fa4ffce SHA512 574717de3250897d5c9b9df9ec7524b77feb9708cb011bf3db77f13f200b2da8adf78670c69673766a73132f1c42e87aabbe71e9ba18da060804f463fe31f925
+EBUILD ruby-ldap-0.9.20.ebuild 1094 BLAKE2B 19aeadb921ef6157271400d39c380663fedb00c06d911cb207dc958ae9914277247613e1c60087c179bb2452cd4103992905cf95820e17db506ccf5be5f42fd4 SHA512 d216783d584d89c19f46f0c16296832f0140454bba0ceed58f22f6101829e56aafb5196b70b34580f6cb3fe15dafe574b7fcd3b9f979a7d30c4736a89c528b1a
MISC metadata.xml 390 BLAKE2B c6e77e29563ead438259a5643f24d5f9d69a3049e0e3a427ee44561f08c72ab2bf8c427a735606ca7a160d0f623538d12ed3d0020e2e817935152f956f70793f SHA512 55f9b63787f86238cf1f6a465e2eea49496be45c0e80fd0175b73434b93f7ce495c46b081833b5f3d7ff3322c1de31c86ba524f3327630908e424b0346dc02b2
diff --git a/dev-ruby/ruby-ldap/ruby-ldap-0.9.20.ebuild b/dev-ruby/ruby-ldap/ruby-ldap-0.9.20.ebuild
new file mode 100644
index 000000000000..c52069c6d7ed
--- /dev/null
+++ b/dev-ruby/ruby-ldap/ruby-ldap-0.9.20.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25"
+
+inherit multilib ruby-fakegem
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_EXTRADOC="ChangeLog FAQ NOTES README TODO"
+
+DESCRIPTION="A Ruby interface to some LDAP libraries"
+HOMEPAGE="https://github.com/bearded/ruby-ldap"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-macos"
+IUSE="ssl"
+DEPEND=">=net-nds/openldap-2
+ dev-libs/cyrus-sasl
+ ssl? ( dev-libs/openssl:0 )"
+RDEPEND="${DEPEND}"
+
+# Current test set is interactive due to certificate generation and requires
+# running LDAP daemon
+RESTRICT="test"
+
+each_ruby_configure() {
+ local myconf="--with-openldap2"
+ if ! use ssl ; then
+ myconf="${myconf} --without-libcrypto --without-libssl"
+ fi
+ ${RUBY} extconf.rb ${myconf} || die "extconf.rb failed"
+ sed -i -e 's:-Wl,--no-undefined::' \
+ -e "s/^ldflags = /ldflags = $\(LDFLAGS\) /" Makefile || die
+}
+
+each_ruby_compile() {
+ emake V=1
+ cp ldap$(get_modname) lib/ || die
+}