summaryrefslogtreecommitdiff
path: root/dev-ruby/ruby-ldap
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /dev-ruby/ruby-ldap
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'dev-ruby/ruby-ldap')
-rw-r--r--dev-ruby/ruby-ldap/Manifest1
-rw-r--r--dev-ruby/ruby-ldap/ruby-ldap-0.9.20-r1.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-ruby/ruby-ldap/Manifest b/dev-ruby/ruby-ldap/Manifest
index 08c63ff13d26..a619e3f1a71f 100644
--- a/dev-ruby/ruby-ldap/Manifest
+++ b/dev-ruby/ruby-ldap/Manifest
@@ -1,3 +1,4 @@
DIST ruby-ldap-0.9.20.gem 67072 BLAKE2B 626a35ab764dacfb37c727d867e1d435222730a3e7ea745ee4e7ec051ce3a822cc5a1230b463bc12f4a2390db667ed3b61deceb9842c014f64cdf43a26d285f9 SHA512 4f4902e7eaf4fe0cd421d58c73ce4e625d61ee20ef02363d3cf5754c66237e0f378ac433b234c2b86d5f5284ae03b7ae6c46d3575c512487bc1a931d021c9517
+EBUILD ruby-ldap-0.9.20-r1.ebuild 902 BLAKE2B 1e6bd3f5914343ea0d8212c41027aa25e26f17fd392b1a40f74314ea8a94f8c71d2c610040364af4c7202c2a439c56ad7408b70594fbc4fc6455142b9b0b6a21 SHA512 4aa370ae4557d7bd7bad686c181f807c1a0c69d6e0c5ca32ee41b7fe4d48c7fba97823a0094bf0f8a61779345cd55bc86b9fb6b8aa091cb010888918dd2daed7
EBUILD ruby-ldap-0.9.20.ebuild 1071 BLAKE2B a7406a767e3d06032ce2277607ddc056e35c6f3b21dc89584771782b78bdee5c1c532586d6e0be0ed3317aa349ed0cc7fcfa470987437f32797f904cfe45806c SHA512 fd81c272b7b6c6264e8c274875ef53ad18f104714bf079709b8cdf59a7bb10ed0dc6f20d67e2c8b439183c7d1acc401e8955f3be8d72020fc6d34869c34f1e26
MISC metadata.xml 391 BLAKE2B c7512c86b40f4a8cd418e12633883da21a0ad0d9de73d05307f5f2b0fc2aca31b9835cd709f5f0a52b487cf7197253a3a2b579d38ff44c91ae50d8469ac3716c SHA512 763bd735ebffb233f9a66e77754de2092c868585565a2c0e770f9e8909d0bf7e3bc312658f6d6d0f124e93c45e06ea9bbd864137ad5d7a1e3979f56e24713180
diff --git a/dev-ruby/ruby-ldap/ruby-ldap-0.9.20-r1.ebuild b/dev-ruby/ruby-ldap/ruby-ldap-0.9.20-r1.ebuild
new file mode 100644
index 000000000000..a195fa0f2b51
--- /dev/null
+++ b/dev-ruby/ruby-ldap/ruby-ldap-0.9.20-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+inherit ruby-fakegem
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_EXTENSIONS=(./extconf.rb)
+RUBY_FAKEGEM_EXTRADOC="ChangeLog FAQ NOTES README TODO"
+
+DESCRIPTION="A Ruby interface to some LDAP libraries"
+HOMEPAGE="https://github.com/bearded/ruby-ldap"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="ssl"
+DEPEND=">=net-nds/openldap-2
+ dev-libs/cyrus-sasl
+ ssl? ( dev-libs/openssl:0 )"
+RDEPEND="${DEPEND}"
+
+# Current test set is interactive due to certificate generation and requires
+# running LDAP daemon
+RESTRICT="test"
+
+each_ruby_configure() {
+ local myconf="--with-openldap2"
+ if ! use ssl ; then
+ myconf="${myconf} --without-libcrypto --without-libssl"
+ fi
+ RUBY_FAKEGEM_EXTENSION_OPTIONS=${myconf} each_fakegem_configure
+}