summaryrefslogtreecommitdiff
path: root/dev-ruby/ruby-ldap/ruby-ldap-0.9.20.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
commit401101f9c8077911929d3f2b60a37098460a5d89 (patch)
treec2bef4719f6787550f0916aeaa8f4f403a9296af /dev-ruby/ruby-ldap/ruby-ldap-0.9.20.ebuild
parent4cbcc855382a06088e2f016f62cafdbcb7e40665 (diff)
gentoo resync : 25.03.2022
Diffstat (limited to 'dev-ruby/ruby-ldap/ruby-ldap-0.9.20.ebuild')
-rw-r--r--dev-ruby/ruby-ldap/ruby-ldap-0.9.20.ebuild41
1 files changed, 0 insertions, 41 deletions
diff --git a/dev-ruby/ruby-ldap/ruby-ldap-0.9.20.ebuild b/dev-ruby/ruby-ldap/ruby-ldap-0.9.20.ebuild
deleted file mode 100644
index 87b4ec31ce48..000000000000
--- a/dev-ruby/ruby-ldap/ruby-ldap-0.9.20.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby24 ruby25 ruby26 ruby27"
-
-inherit multilib ruby-fakegem
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-RUBY_FAKEGEM_TASK_TEST=""
-RUBY_FAKEGEM_EXTRADOC="ChangeLog FAQ NOTES README TODO"
-
-DESCRIPTION="A Ruby interface to some LDAP libraries"
-HOMEPAGE="https://github.com/bearded/ruby-ldap"
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc x86"
-IUSE="ssl"
-DEPEND=">=net-nds/openldap-2
- dev-libs/cyrus-sasl
- ssl? ( dev-libs/openssl:0 )"
-RDEPEND="${DEPEND}"
-
-# Current test set is interactive due to certificate generation and requires
-# running LDAP daemon
-RESTRICT="test"
-
-each_ruby_configure() {
- local myconf="--with-openldap2"
- if ! use ssl ; then
- myconf="${myconf} --without-libcrypto --without-libssl"
- fi
- ${RUBY} extconf.rb ${myconf} || die "extconf.rb failed"
- sed -i -e 's:-Wl,--no-undefined::' \
- -e "s/^ldflags = /ldflags = $\(LDFLAGS\) /" Makefile || die
-}
-
-each_ruby_compile() {
- emake V=1
- cp ldap$(get_modname) lib/ || die
-}