summaryrefslogtreecommitdiff
path: root/dev-ruby/ruby-gobject-introspection
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/ruby-gobject-introspection
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/ruby-gobject-introspection')
-rw-r--r--dev-ruby/ruby-gobject-introspection/Manifest5
-rw-r--r--dev-ruby/ruby-gobject-introspection/metadata.xml12
-rw-r--r--dev-ruby/ruby-gobject-introspection/ruby-gobject-introspection-3.1.1.ebuild33
-rw-r--r--dev-ruby/ruby-gobject-introspection/ruby-gobject-introspection-3.2.7.ebuild36
4 files changed, 86 insertions, 0 deletions
diff --git a/dev-ruby/ruby-gobject-introspection/Manifest b/dev-ruby/ruby-gobject-introspection/Manifest
new file mode 100644
index 000000000000..203014766dbd
--- /dev/null
+++ b/dev-ruby/ruby-gobject-introspection/Manifest
@@ -0,0 +1,5 @@
+DIST ruby-gnome2-all-3.1.1.tar.gz 2233259 BLAKE2B 2758a2b34bbb96a9b2aba73f576d6213c9add2bd37ac85ed083a2bfb050d5327d7332ee1b9a8445e69aab0c4721ba446b4cb66c26273818ba930cce389eda152 SHA512 be264505d254248e0e6190b28c5311d10384c2ade19ac56f249bd17284b153368e6007862c4e19e6d1015ba3e441f9bc502a5dbcc45b7dc8036611ef554a6de9
+DIST ruby-gnome2-all-3.2.7.tar.gz 2290033 BLAKE2B 48abafe9c108f3a42b5da05edb6aa7ea6b508e313f65954481d3ce1f1c4497adfce52d83d491314f352fd057ac31fad63d2c1ec4b13fb0f6de1f6f9ab12d35c6 SHA512 94c273941918e49f140cd5dcc413421406e4b15ad244f6a4c29255030162aaae13dacb701c3df20a64ac6945b7cc4a5de0fa8bed21b4f119183641d298bc2030
+EBUILD ruby-gobject-introspection-3.1.1.ebuild 921 BLAKE2B d33a569536b7172022a14c3190bdc7ea86cf9677be94d47d67e67b5c1802b28c624059e9c2c199795defecab13e9d40dbca6f7ef85772f0c77892ea3a43b8847 SHA512 987d2a96753ee5cb3ffa9de7b8d702e9f5f954a6678a4292f043d9bb23245f64cd99b61d5592b2784bef7dfaddb96900ac2fb5d67663e80a3195940703b191d6
+EBUILD ruby-gobject-introspection-3.2.7.ebuild 1061 BLAKE2B ae34d010adb89f605f1cc6ed9dbbfa41f573f560163e5de525e8dd9dcddee0d819ab3b7b0fac3dc6c1f7f17d3d5ead97ad548703141eb42210bccd284bdb44e9 SHA512 741f385dc08b234c45ff9c40a92d8c1dc4d1e978aa1f0e3ac632fe810d2d2a7522e4b88bbefe6f46df300406a81aefa5b11622490b9146f93478bbc6966b55b1
+MISC metadata.xml 391 BLAKE2B b68c9928d0cae2572bb8737d6a9b5aa90acd0fea2ef7c1de4fa0e2079685cb69b508107f6c651e21fe747d86a4caf0a7171086b2bd6c35af0721cde99f7ec8f3 SHA512 84903daa0e4584dd1e631df4a25becbd4e1a599c998d0384978fa82d971a6fd119e920fd0e4830771a98efd3075f1529a6bfbd64739bdecaa22ec70f31be1ab2
diff --git a/dev-ruby/ruby-gobject-introspection/metadata.xml b/dev-ruby/ruby-gobject-introspection/metadata.xml
new file mode 100644
index 000000000000..2eb590f61d26
--- /dev/null
+++ b/dev-ruby/ruby-gobject-introspection/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge-jp">ruby-gnome2</remote-id>
+ <remote-id type="sourceforge">ruby-gnome2</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/ruby-gobject-introspection/ruby-gobject-introspection-3.1.1.ebuild b/dev-ruby/ruby-gobject-introspection/ruby-gobject-introspection-3.1.1.ebuild
new file mode 100644
index 000000000000..b3e30f273114
--- /dev/null
+++ b/dev-ruby/ruby-gobject-introspection/ruby-gobject-introspection-3.1.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+inherit ruby-ng-gnome2
+
+RUBY_S=ruby-gnome2-all-${PV}/gobject-introspection
+
+DESCRIPTION="Ruby GObjectIntrospection bindings"
+KEYWORDS="amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND+=" dev-libs/gobject-introspection"
+RDEPEND+=" dev-libs/gobject-introspection"
+
+ruby_add_rdepend "~dev-ruby/ruby-glib2-${PV}"
+
+all_ruby_prepare() {
+ # Remove pregenerated Makefile since it will otherwise be shared by all targets.
+ rm -f Makefile Makefile.lib ext/gobject-introspection/Makefile || die
+
+ # Avoid unneeded dependency on test-unit-notify.
+ sed -i -e '/notify/ s:^:#:' test/gobject-introspection-test-utils.rb || die
+
+ # Avoid compilation of dependencies during test.
+ sed -i -e '/system/,/^ end/ s:^:#:' test/run-test.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} test/run-test.rb || die
+}
diff --git a/dev-ruby/ruby-gobject-introspection/ruby-gobject-introspection-3.2.7.ebuild b/dev-ruby/ruby-gobject-introspection/ruby-gobject-introspection-3.2.7.ebuild
new file mode 100644
index 000000000000..9ab41783c3a9
--- /dev/null
+++ b/dev-ruby/ruby-gobject-introspection/ruby-gobject-introspection-3.2.7.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby23 ruby24 ruby25"
+
+inherit ruby-ng-gnome2
+
+RUBY_S=ruby-gnome2-all-${PV}/gobject-introspection
+
+DESCRIPTION="Ruby GObjectIntrospection bindings"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND+=" dev-libs/gobject-introspection"
+RDEPEND+=" dev-libs/gobject-introspection"
+
+ruby_add_rdepend "~dev-ruby/ruby-glib2-${PV}"
+
+all_ruby_prepare() {
+ # Remove pregenerated Makefile since it will otherwise be shared by all targets.
+ rm -f Makefile Makefile.lib ext/gobject-introspection/Makefile || die
+
+ # Avoid native installer
+ sed -i -e '/native-package-installer/ s:^:#: ; /^\s*setup_homebrew_libffi/ s:^:#:' ../glib2/lib/mkmf-gnome2.rb || die
+
+ # Avoid unneeded dependency on test-unit-notify.
+ sed -i -e '/notify/ s:^:#:' test/gobject-introspection-test-utils.rb || die
+
+ # Avoid compilation of dependencies during test.
+ sed -i -e '/system/,/^ end/ s:^:#:' test/run-test.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} test/run-test.rb || die
+}