summaryrefslogtreecommitdiff
path: root/dev-ruby/ruby-gdkpixbuf2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/ruby-gdkpixbuf2
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/ruby-gdkpixbuf2')
-rw-r--r--dev-ruby/ruby-gdkpixbuf2/Manifest3
-rw-r--r--dev-ruby/ruby-gdkpixbuf2/metadata.xml12
-rw-r--r--dev-ruby/ruby-gdkpixbuf2/ruby-gdkpixbuf2-3.1.1.ebuild39
3 files changed, 54 insertions, 0 deletions
diff --git a/dev-ruby/ruby-gdkpixbuf2/Manifest b/dev-ruby/ruby-gdkpixbuf2/Manifest
new file mode 100644
index 000000000000..31f1a72a1ac5
--- /dev/null
+++ b/dev-ruby/ruby-gdkpixbuf2/Manifest
@@ -0,0 +1,3 @@
+DIST ruby-gnome2-all-3.1.1.tar.gz 2233259 BLAKE2B 2758a2b34bbb96a9b2aba73f576d6213c9add2bd37ac85ed083a2bfb050d5327d7332ee1b9a8445e69aab0c4721ba446b4cb66c26273818ba930cce389eda152 SHA512 be264505d254248e0e6190b28c5311d10384c2ade19ac56f249bd17284b153368e6007862c4e19e6d1015ba3e441f9bc502a5dbcc45b7dc8036611ef554a6de9
+EBUILD ruby-gdkpixbuf2-3.1.1.ebuild 650 BLAKE2B 4cd4a03c3f0cf1b48d144cc48763a35db931b8c3f431cc3c5e99d1a02debceff24d73cb1b23ded11bafde0f2f614fdf27ead895f3dbb5bbae916c53249539d07 SHA512 49f6f95347679bf0f0cfe7832796908580867280ddb5c47fa355344f0c2e3b7dcf8cb9d117f0c1d865aab4fc500b456a3b04c3609c8c2c8a0f52f33adc712cc4
+MISC metadata.xml 391 BLAKE2B b68c9928d0cae2572bb8737d6a9b5aa90acd0fea2ef7c1de4fa0e2079685cb69b508107f6c651e21fe747d86a4caf0a7171086b2bd6c35af0721cde99f7ec8f3 SHA512 84903daa0e4584dd1e631df4a25becbd4e1a599c998d0384978fa82d971a6fd119e920fd0e4830771a98efd3075f1529a6bfbd64739bdecaa22ec70f31be1ab2
diff --git a/dev-ruby/ruby-gdkpixbuf2/metadata.xml b/dev-ruby/ruby-gdkpixbuf2/metadata.xml
new file mode 100644
index 000000000000..2eb590f61d26
--- /dev/null
+++ b/dev-ruby/ruby-gdkpixbuf2/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge-jp">ruby-gnome2</remote-id>
+ <remote-id type="sourceforge">ruby-gnome2</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/ruby-gdkpixbuf2/ruby-gdkpixbuf2-3.1.1.ebuild b/dev-ruby/ruby-gdkpixbuf2/ruby-gdkpixbuf2-3.1.1.ebuild
new file mode 100644
index 000000000000..28469a4ff259
--- /dev/null
+++ b/dev-ruby/ruby-gdkpixbuf2/ruby-gdkpixbuf2-3.1.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby21 ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_NAME="gdk_pixbuf2"
+
+inherit ruby-ng-gnome2
+
+RUBY_S=ruby-gnome2-all-${PV}/${RUBY_FAKEGEM_NAME}
+
+DESCRIPTION="Ruby GdkPixbuf2 bindings"
+KEYWORDS="amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND+=" x11-libs/gtk+:2"
+
+ruby_add_rdepend "
+ >=dev-ruby/ruby-gio2-${PV}
+ >=dev-ruby/ruby-glib2-${PV}
+ >=dev-ruby/ruby-gobject-introspection-${PV}
+"
+
+each_ruby_configure() {
+ :
+}
+
+each_ruby_compile() {
+ :
+}
+
+each_ruby_test() {
+ ${RUBY} test/run-test.rb || die
+}
+
+each_ruby_install() {
+ each_fakegem_install
+}