summaryrefslogtreecommitdiff
path: root/dev-ruby/ruby-gdkpixbuf2/ruby-gdkpixbuf2-3.3.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-08 01:07:24 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-08 01:07:24 +0100
commite3cf2c86fca1750343c1885311f857f185ee4f2d (patch)
treed9d1fbc20509d4c90f57fb2d9e1459bc8034c831 /dev-ruby/ruby-gdkpixbuf2/ruby-gdkpixbuf2-3.3.7.ebuild
parentf1af93971b7490792d8541bc790e0d8c6d787059 (diff)
gentoo resync : 08.09.2019
Diffstat (limited to 'dev-ruby/ruby-gdkpixbuf2/ruby-gdkpixbuf2-3.3.7.ebuild')
-rw-r--r--dev-ruby/ruby-gdkpixbuf2/ruby-gdkpixbuf2-3.3.7.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-ruby/ruby-gdkpixbuf2/ruby-gdkpixbuf2-3.3.7.ebuild b/dev-ruby/ruby-gdkpixbuf2/ruby-gdkpixbuf2-3.3.7.ebuild
new file mode 100644
index 000000000000..bdf7742116e2
--- /dev/null
+++ b/dev-ruby/ruby-gdkpixbuf2/ruby-gdkpixbuf2-3.3.7.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_NAME="gdk_pixbuf2"
+
+inherit ruby-ng-gnome2
+
+RUBY_S=ruby-gnome2-all-${PV}/${RUBY_FAKEGEM_NAME}
+
+DESCRIPTION="Ruby GdkPixbuf2 bindings"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND+=" x11-libs/gtk+:2"
+
+ruby_add_rdepend "
+ ~dev-ruby/ruby-gio2-${PV}
+"
+
+each_ruby_configure() {
+ :
+}
+
+each_ruby_compile() {
+ :
+}
+
+each_ruby_test() {
+ ${RUBY} test/run-test.rb || die
+}
+
+each_ruby_install() {
+ each_fakegem_install
+}