summaryrefslogtreecommitdiff
path: root/dev-ruby/rspectacular
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ruby/rspectacular
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ruby/rspectacular')
-rw-r--r--dev-ruby/rspectacular/Manifest5
-rw-r--r--dev-ruby/rspectacular/metadata.xml11
-rw-r--r--dev-ruby/rspectacular/rspectacular-0.70.7.ebuild23
3 files changed, 39 insertions, 0 deletions
diff --git a/dev-ruby/rspectacular/Manifest b/dev-ruby/rspectacular/Manifest
new file mode 100644
index 000000000000..63bb8d5bdf57
--- /dev/null
+++ b/dev-ruby/rspectacular/Manifest
@@ -0,0 +1,5 @@
+DIST rspectacular-0.70.7.gem 16384 SHA256 c2dc854ad3c4ed8a745971003df5e9db4aaefb7fe9251b664510c6ea59e10fd4 SHA512 dab67e89dd88cfb8741be10c385d58b3437245c623700f0d651dd4e96bcf28f063a9dd952098eb574bbadaeb077ebe7e0f9db7d6e83648c1de9a4f0c390fe567 WHIRLPOOL 47c7b60a7f7863919df8bac084c7779e79d906e25c05622dc6fd9ca7dba9802fad8d99f30ee7f199e6ae901622788490ce9da3ec180a8f7026b45e290ccbf86b
+EBUILD rspectacular-0.70.7.ebuild 656 SHA256 518328b36097fa3640cde9ca4829d5ce9be95ec529429e9e71f5d108bb35f619 SHA512 bacba6d8faf53390753d1af1ad18348bdace0c3c94c4091c0f46c89fcac90cb49bf57874217f9d1d0db370e67274aedca6e3878b3aec882b9f3023c5aa94d53c WHIRLPOOL fa8a406d05749399710b52592cd070545ee18cffd229bc000323d8203819990e381f40beaca1af90aef716c392561157ce9b7f3605d7d890ab111f535ba5900b
+MISC ChangeLog 3939 SHA256 56d12113e512883d43bd13f90b165940bd29b7a1a83ed956b5645d92163afd56 SHA512 e061933127d136b5f444e218085276d81765d2d4797e895dd632de2a256b8a537660fd8c6ccad217298d3d002ef99ab4bf2c588f7170f58c380a5f4a5a49f743 WHIRLPOOL 254c3abd86109daa4e26f33699afb45b47cd3b40a95dce181d898e3dfd8cab0ab8383205bba0da47cdadf285cc39da390fb134a08b86c60b687b5f7f51c1f386
+MISC ChangeLog-2015 1565 SHA256 f7a001ea5d4a48aaf8aa012a7d89c822fbbc50890dd6bf7a4ea861f5111e2d25 SHA512 bf768de585bd8d09dd578d7ad6b85e61503d945cadf1b37023853c660bf754cb13edc1d19d2dcb0949a62497450833865af5cccab43bbfc008544bbb26cd6500 WHIRLPOOL b855a9d1c7dea20738408356a3690c511ecc0fa112ee64189c645809ff8a1a495bf55b4a636e65b3b02b3d39b7e9986aca1fca0e9bcd36633dae2f67ef5377b9
+MISC metadata.xml 350 SHA256 02429089e8ae67753e126663404e2933a6c265b2d613a3a05765661ae0063a6b SHA512 78e3ba17336c86b92811af99283d12b0bc191a2f06d907d0c792aedc17d5a39d81d00acb4b884f074103cbca587c3961dace871fc82e4a9a3fc6a9190c48b75d WHIRLPOOL f6e344213f7b72add426d6dfc8833073b07b3b9ab88c8eb3553b05b968c9179dd1929590d7960180dc4bba83d8b1b440f1f1fb52b6593d50ae99df7d823f5e97
diff --git a/dev-ruby/rspectacular/metadata.xml b/dev-ruby/rspectacular/metadata.xml
new file mode 100644
index 000000000000..b163c4361c7c
--- /dev/null
+++ b/dev-ruby/rspectacular/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">thekompanee/rspectacular</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/rspectacular/rspectacular-0.70.7.ebuild b/dev-ruby/rspectacular/rspectacular-0.70.7.ebuild
new file mode 100644
index 000000000000..675f377b7356
--- /dev/null
+++ b/dev-ruby/rspectacular/rspectacular-0.70.7.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby20 ruby21 ruby22 ruby23"
+
+RUBY_FAKEGEM_TASK_TEST=""
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="RSpec support and matchers"
+HOMEPAGE="https://github.com/thekompanee/rspectacular"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/rspec-3.1:3 dev-ruby/fuubar:2 dev-ruby/shoulda-matchers:3"