summaryrefslogtreecommitdiff
path: root/dev-ruby/rspec-support
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-01-12 16:58:08 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-01-12 16:58:08 +0000
commitc8a77dfe4d3d307c1d5dd2650b7297447d8b609d (patch)
tree9ea78393bc3ecd6ab4de449383d4e97e5f3648ae /dev-ruby/rspec-support
parent2891d29af8907ce881662f4a02844926d7a293c7 (diff)
gentoo resync : 12.01.2019
Diffstat (limited to 'dev-ruby/rspec-support')
-rw-r--r--dev-ruby/rspec-support/Manifest2
-rw-r--r--dev-ruby/rspec-support/rspec-support-3.8.0.ebuild8
2 files changed, 7 insertions, 3 deletions
diff --git a/dev-ruby/rspec-support/Manifest b/dev-ruby/rspec-support/Manifest
index 78789aa19161..6ed0585bb239 100644
--- a/dev-ruby/rspec-support/Manifest
+++ b/dev-ruby/rspec-support/Manifest
@@ -1,5 +1,5 @@
DIST rspec-support-3.7.1-git.tgz 65831 BLAKE2B 8595c496bc8d13e36fdfd4a8be8e055db4ac1e85af63f99158d191c9ef9e0a6ba0a2972ad7661a63eeda959e2969139a99ded71219777fd493544b711b6fea53 SHA512 a5760d696048897d76c665a756474bbb1a1995891e577c989cf68a205644c8608c538bf3d87c558428e2c412e02d3552d47567a0679cd4f8793c06f43eccf459
DIST rspec-support-3.8.0-git.tgz 68415 BLAKE2B c1b13d639213e03c4e334de5520f19136da0e25e96a93b685776a691a84dc1daa66e4dacf3feb83b01032cb1364ba16cdfccf19e738264bbc3bef20882a89d8a SHA512 e16cc7bcc3de797e78c4f6ed475b0e60d492d0442dc048b4b2769a4819b80d1fb4a12aefaee3cc6a35f08d35f5fea82e00cc0fcf04363e57e74a6f5ed73d0693
EBUILD rspec-support-3.7.1.ebuild 1338 BLAKE2B 6351c97df0b5f3e550ce631758a809e010e025504e6c6487c5927c5644b1f9dca1732b7b37321486c809946c73bf3053fa25ce51cc2df4b6940b2d5fbca0b3b5 SHA512 fcc33d32798d509eb81b83b2713fdff45f9dd59fdd8742a075320b376867c9284f421639d26db14dac45a9f9a00536e74ce52ab6501332372cf2b0299d4ba734
-EBUILD rspec-support-3.8.0.ebuild 1351 BLAKE2B 36e3b765c3ffc5a12d2bb2c76754255e19cff7595ac8624ea755fdc13f4a4df1a0c6ef66c4b7ad56feaed83181f4112c14d1b2f8a1dac34cbb8f1bc827a20351 SHA512 5020cfcfd026a57fbfb79bf1856bd9ddaa905381f24701788e3c12a33d66d42f6ad32350189180bcee6ba7da39ee3edd9ceaa342b367d2f39d1e55de27520893
+EBUILD rspec-support-3.8.0.ebuild 1588 BLAKE2B c2de6ccb1d9072a03fe9c972dbf0097e0a21de82787ac702856a7d6fbc0a2bd5eb28c619dae20d8c1345ccee0a576c7c7d768e815215ebc0cf34851f4c391b0f SHA512 5690a80daaac0acfc008724c77a8971af0f9f5bce4ff9c5162913a502b9d6735426a2baaf0f0d6e5f71d810cab1938837fcacff8b04b35786158995a9b096d38
MISC metadata.xml 345 BLAKE2B 832a39e1b38a33b4b5238aaf4a79f08aaff0a7751d466ebe3dd6eeaca493cd10d7ed51766d12c17f589be48d450d3f7a36690ee171a5c650c1cdad334003446f SHA512 71b6ed77045b94efb05b0275574fdcf328678c7d0aef385703a40f5ff3300653638dc32911ff8f91c66881201c735df930c000c0283afa9f189dbba41e97628c
diff --git a/dev-ruby/rspec-support/rspec-support-3.8.0.ebuild b/dev-ruby/rspec-support/rspec-support-3.8.0.ebuild
index e84bff1cedb7..49f58a42c922 100644
--- a/dev-ruby/rspec-support/rspec-support-3.8.0.ebuild
+++ b/dev-ruby/rspec-support/rspec-support-3.8.0.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-USE_RUBY="ruby23 ruby24 ruby25"
+USE_RUBY="ruby23 ruby24 ruby25 ruby26"
RUBY_FAKEGEM_RECIPE_TEST="rspec3"
RUBY_FAKEGEM_RECIPE_DOC="rdoc"
@@ -36,4 +36,8 @@ all_ruby_prepare() {
# Avoid a spec requiring a specific locale
sed -i -e '/copes with encoded strings/ s/RSpec::Support::OS.windows?/true/' spec/rspec/support/differ_spec.rb || die
+
+ # Avoid a brittle spec depending on ruby implementation details
+ # should be fixed upstream in next version
+ sed -i -e '/returns a hash containing nodes for each line number/askip "ruby26"' spec/rspec/support/source_spec.rb || die
}