summaryrefslogtreecommitdiff
path: root/dev-ruby/rspec-support
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-08 15:59:10 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-08 15:59:10 +0000
commitba7a238ca9c95cb73dc1040bfe42d78dd6970126 (patch)
tree832e7f8a61ef6de3aa7c7b5c652e5b951d827194 /dev-ruby/rspec-support
parent31a02d889028bf30f7b376b935aa05c2140d3c66 (diff)
gentoo auto-resync : 08:02:2024 - 15:59:10
Diffstat (limited to 'dev-ruby/rspec-support')
-rw-r--r--dev-ruby/rspec-support/Manifest2
-rw-r--r--dev-ruby/rspec-support/rspec-support-3.12.2.ebuild56
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-ruby/rspec-support/Manifest b/dev-ruby/rspec-support/Manifest
index 556f5a83bf00..e95f92af6cd8 100644
--- a/dev-ruby/rspec-support/Manifest
+++ b/dev-ruby/rspec-support/Manifest
@@ -1,3 +1,5 @@
DIST rspec-support-3.12.1-git.tgz 78764 BLAKE2B f3e6cd0123096971ee2793a69d02e4c34289904285ee9fe7081f7697c724ecc4195a3cc0e8042bd0c76ff070d6c332fbe41862c31afad9089f68f3846a613dd6 SHA512 88577e184a90f9f48ea97a53e5bd0bd6a2fd5e43275c4bd5cf52a4f8a36637ddb0a1043723b5902d3c0b5bd0cfe0c17a035af702cb094fb8c9543fae6401768a
+DIST rspec-support-3.12.2-git.tgz 79544 BLAKE2B 874196a4c6fded0254c33d3959a7827d1bf9a85976b9cb975ecc7767d2e1bf094cdf3d95b0533560505dc80dfcd4b945cb88d673430b85a239936735844706ef SHA512 76748d3ca1d9415e15f0be8f14b99f9d16fd6b20548913915ab3e2d56dfe94fa744a9c97ec0747bfa66360cebd6584881e8997ecf46baf45c508f14f96bc644a
EBUILD rspec-support-3.12.1.ebuild 1864 BLAKE2B 7ef93481037f3f7f940d78b69c2dadc3ff20178fc0887c10543f47fb6b6bd81d7e39aa0dd395338d9441a99ad53f2caecdee63deb3ebdd2b1b15f033dca61efb SHA512 da4540ba2637aeacc73e51825e56afe4191cf685a4c502e0ec38f282e7afa8fbce4dccd909495be551f3b93f0227ed345340a93657c7bac572a3b5d2bc06a1fd
+EBUILD rspec-support-3.12.2.ebuild 1879 BLAKE2B 9749dbf0afd270ca633b8dbad94c064b9f2a6aadb29cc0083616711a0a074331b31369e1af1f2049382bf6a044498a39eab4788ebb9fe4119365b844083dc49e SHA512 8991e0133a60ac023d9a590f74ef650a5bcbbc7c92ea66b2a3e47a7d2a0b0e9f2253f8d7a6caae758f76eec7c3fb7ef343cb9927905594e24e8c5e327422e5ad
MISC metadata.xml 346 BLAKE2B 74d62cfe1930a3bfaad9b1b14ce55b0de81a0963f1e4e5ba0f104ea51adac0ba86c7cbc38831630029a8e487623df0d279028b5d1b2391eb2bdf060582c80be4 SHA512 60c7dd2d3d9d103b3c0e505d62975571eab89bdbc92203c2bff8cd9b854dda3020490f9592464760798b8e5d973ab3be7b142dca2d03583b822fb0a83761a225
diff --git a/dev-ruby/rspec-support/rspec-support-3.12.2.ebuild b/dev-ruby/rspec-support/rspec-support-3.12.2.ebuild
new file mode 100644
index 000000000000..ba109801fee2
--- /dev/null
+++ b/dev-ruby/rspec-support/rspec-support-3.12.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
+HOMEPAGE="https://github.com/rspec/rspec-support"
+SRC_URI="https://github.com/rspec/${PN}/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="test"
+
+ruby_add_bdepend "test? ( >=dev-ruby/rspec-3.9.0:3 >=dev-ruby/thread_order-1.1.0 )"
+
+all_ruby_prepare() {
+ sed -i -e '/git ls-files/d' ${RUBY_FAKEGEM_GEMSPEC} || die
+
+ # Remove spec that, by following symlinks, tries to scan pretty much
+ # the whole filesystem.
+ rm spec/rspec/support/caller_filter_spec.rb || die
+
+ # Avoid spec that requires a dependency on git
+ sed -i -e '/library wide checks/,/]/ s:^:#:' spec/rspec/support_spec.rb || die
+
+ # Avoid a spec requiring a specific locale
+ sed -i -e '/copes with encoded strings/ s/RSpec::Support::OS.windows?/true/' spec/rspec/support/differ_spec.rb || die
+}
+
+each_ruby_prepare() {
+ # Use the ruby version being tested
+ sed -i -e '/shell_out/ s:ruby:'${RUBY}':' spec/rspec/support/spec/shell_out_spec.rb || die
+
+ case ${RUBY} in
+ *ruby31|*ruby32|*ruby33)
+ # Avoid specs failing when run in Gentoo, possibly due to different IO
+ sed -e '/outputs unified diff message of two arrays/askip "ruby31 IO"' \
+ -e '/outputs unified diff message for hashes inside arrays with differing key orders/askip "ruby31 IO"' \
+ -i spec/rspec/support/differ_spec.rb || die
+ ;;
+ esac
+}
+
+each_ruby_test() {
+ RUBYLIB=lib ${RUBY} -S rspec spec || die
+}