summaryrefslogtreecommitdiff
path: root/dev-ruby/rspec-retry/rspec-retry-0.6.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-10 10:35:29 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-10 10:35:29 +0100
commit5067796b074450a155155c782ef4885c885cfb2b (patch)
tree68109e52982e612f48c05614ff09888cb33668ac /dev-ruby/rspec-retry/rspec-retry-0.6.2.ebuild
parent68d015b395b17126b8651edb61c80fca8c5968c1 (diff)
gentoo auto-resync : 10:09:2023 - 10:35:29
Diffstat (limited to 'dev-ruby/rspec-retry/rspec-retry-0.6.2.ebuild')
-rw-r--r--dev-ruby/rspec-retry/rspec-retry-0.6.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ruby/rspec-retry/rspec-retry-0.6.2.ebuild b/dev-ruby/rspec-retry/rspec-retry-0.6.2.ebuild
new file mode 100644
index 000000000000..96652e217e87
--- /dev/null
+++ b/dev-ruby/rspec-retry/rspec-retry-0.6.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="changelog.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Retry randomly failing rspec example"
+HOMEPAGE="https://github.com/NoRedInk/rspec-retry"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/rspec-core-3.3"
+
+all_ruby_prepare() {
+ sed -i -e '/pry/ s:^:#:' spec/spec_helper.rb || die
+
+ # Avoid specs accessing class variables from the top level
+ sed -e '/with :retry => 0/ s/context/xcontext/' \
+ -e '/should be exposed/ s/it/xit/' \
+ -i spec/lib/rspec/retry_spec.rb || die
+}