summaryrefslogtreecommitdiff
path: root/dev-ruby/rspec-pending_for
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-19 08:38:29 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-19 08:38:29 +0100
commitdbb637a643576bbb9286907cd6c73e3cda3ca1f6 (patch)
treee2431b0c6a4b1c6787601ecc675d72401b00cd3a /dev-ruby/rspec-pending_for
parentb5c8e7977a8950fe976559fbed28db9c0bcd3d6f (diff)
gentoo auto-resync : 19:07:2022 - 08:38:29
Diffstat (limited to 'dev-ruby/rspec-pending_for')
-rw-r--r--dev-ruby/rspec-pending_for/Manifest3
-rw-r--r--dev-ruby/rspec-pending_for/metadata.xml11
-rw-r--r--dev-ruby/rspec-pending_for/rspec-pending_for-0.1.16.ebuild31
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-ruby/rspec-pending_for/Manifest b/dev-ruby/rspec-pending_for/Manifest
new file mode 100644
index 000000000000..fc494d4c8c53
--- /dev/null
+++ b/dev-ruby/rspec-pending_for/Manifest
@@ -0,0 +1,3 @@
+DIST rspec-pending_for-0.1.16.tar.gz 12841 BLAKE2B fb95f7e21e681454252e6dd625c7a7766ee5853ec60f3280c25e591d91a6163dd307ed8583d6e966cca9f1eeac3e3d8543a539f557abaaf41ae424dc8d91d68a SHA512 4d87c82814a2b8f51f79d1c22030870dce98b846add8cab8897d211129ab2116dd28fffe4999e42c35f70393d90448b11067be424af28594600c7dd461de2e80
+EBUILD rspec-pending_for-0.1.16.ebuild 785 BLAKE2B 8c1fc53207f45c257136df253be441ed94749d48d6e51db3be8ead71d1e6d6000510a025adea82ec9475752cbcc5fa144ac376ac8dc4fed62e7319a27328eb21 SHA512 b7836e19d66eb03604b12f94bb942a399ae1000cf23039761f275951376d05c31c8738234ffdcaf8d69adb5911ec0b78ef614a742990b80ca72054046a722a9f
+MISC metadata.xml 342 BLAKE2B dd9203a2e3f822aee7385d608829ca3e51794bae18524879c30b24fae18ed7d4d657209d531a6f9d56a48d280083b79207e7ddeff18989c9bead1c8d05b6efed SHA512 e0b0bdc8984a8adab71d1db7787dfbd7155bfa6b9dbae75468086d202d09c628e78c731b6224861b031f6458f5eef5757231ae87d7af5822e7a447483f75e7be
diff --git a/dev-ruby/rspec-pending_for/metadata.xml b/dev-ruby/rspec-pending_for/metadata.xml
new file mode 100644
index 000000000000..b04340acafd3
--- /dev/null
+++ b/dev-ruby/rspec-pending_for/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">pboling/rspec-pending_for</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/rspec-pending_for/rspec-pending_for-0.1.16.ebuild b/dev-ruby/rspec-pending_for/rspec-pending_for-0.1.16.ebuild
new file mode 100644
index 000000000000..3270a09848cf
--- /dev/null
+++ b/dev-ruby/rspec-pending_for/rspec-pending_for-0.1.16.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby27 ruby30 ruby31"
+
+RUBY_FAKEGEM_BINWRAP=""
+RUBY_FAKEGEM_EXTRADOC="README.md"
+RUBY_FAKEGEM_GEMSPEC="rspec-pending_for.gemspec"
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Mark specs pending or skipped for specific Ruby engine / version combinations"
+HOMEPAGE="https://github.com/pboling/rspec-pending_for"
+SRC_URI="https://github.com/pboling/rspec-pending_for/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_rdepend "
+ dev-ruby/rspec-core
+ dev-ruby/ruby_engine:2
+ dev-ruby/ruby_version:1
+"
+
+all_ruby_prepare() {
+ sed -i -e '/simplecov/ s:^:#:' spec/spec_helper.rb || die
+}