summaryrefslogtreecommitdiff
path: root/dev-ruby/rspec-mocks
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-08 15:59:10 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-08 15:59:10 +0000
commitba7a238ca9c95cb73dc1040bfe42d78dd6970126 (patch)
tree832e7f8a61ef6de3aa7c7b5c652e5b951d827194 /dev-ruby/rspec-mocks
parent31a02d889028bf30f7b376b935aa05c2140d3c66 (diff)
gentoo auto-resync : 08:02:2024 - 15:59:10
Diffstat (limited to 'dev-ruby/rspec-mocks')
-rw-r--r--dev-ruby/rspec-mocks/Manifest2
-rw-r--r--dev-ruby/rspec-mocks/rspec-mocks-3.12.7.ebuild54
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-ruby/rspec-mocks/Manifest b/dev-ruby/rspec-mocks/Manifest
index 633fcbce0dc5..19eda5aff4f0 100644
--- a/dev-ruby/rspec-mocks/Manifest
+++ b/dev-ruby/rspec-mocks/Manifest
@@ -1,3 +1,5 @@
DIST rspec-mocks-3.12.6-git.tgz 207213 BLAKE2B 0b8bded9c6a04bb79910784e67f97028b9935b9e20e6934c3d1cccdf7b981b386a8dfb2e5e0c1f58fbbc2006fb68dabb108444b0f284b7f7f3b39bb73cb01cdc SHA512 f11ef99bdef109e3b332e0cc79e0d9c46db906b0c939ec6a89782219cea03e6282fe867212caaf2bf2eb272ed7ae1f4fe059a5626d131141925f731fcda3e91d
+DIST rspec-mocks-3.12.7-git.tgz 208127 BLAKE2B 86ef82c47ae7ef4992c6394718ee29f91fde70967b7f8ba3101c6f0233ab32be22c9e0e69e9041e94b4e5a587e3e936f89a14dbf464c2bdd8f6ce7d827cc5448 SHA512 c168eb653b585a37052870521e88be0723eba1b2f7f373a04557813e75a62c67448577809fbe1c0d04b21311b29c9874ed7509800bc7c05cb618f208066c8eac
EBUILD rspec-mocks-3.12.6.ebuild 1588 BLAKE2B 6eaa22c0ba401e9bc9121561d1a10f7468473c4d46760a0f0ad577e10072f392264362e8b578fce9b872d31941b58f372f10dd3b195d19179993b674bb485dc0 SHA512 cc7df0564e7cc1612ffc23fd0936a180466da4564baa3633fe270e2f7b29e815250de2bdf329689ff604b86ab832f1dc637e165df17a4ae3d70a47dfa672d050
+EBUILD rspec-mocks-3.12.7.ebuild 1603 BLAKE2B d5797c54ff68f0da2a531b42331110c6e4ddc08272ad747d41032f95f4a59f0ec6fe386aa012a4a00c8e387415a6ca9227fbcf3c8b1bd36270a84ece47e1726b SHA512 a7b37bf38da3ba8226f11b5514cdb0e2742771811716cdd0b3482d0b834ff26fca4def10e19bce5e2994cccbdaa0b7921bec87f298ca256f2c1ba18fb8c1fafb
MISC metadata.xml 344 BLAKE2B 5b939c668a8c75c33348bff9e8a0fa6042702fb59cdfdc2c8b45db1d9d191950a63d6f9b1329e6a2717a097d7b001afecb9ebbd0fa08badaf95664d37b06eb17 SHA512 026e9a293c2f99d86a11f37267fddcf54dbdc33aec00f470a988d477d6e3198ccc478c03cca059be0a4e324b9f256719c99c7c81af97c75fd7cebab433d4b1a1
diff --git a/dev-ruby/rspec-mocks/rspec-mocks-3.12.7.ebuild b/dev-ruby/rspec-mocks/rspec-mocks-3.12.7.ebuild
new file mode 100644
index 000000000000..113c3889a987
--- /dev/null
+++ b/dev-ruby/rspec-mocks/rspec-mocks-3.12.7.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby31 ruby32 ruby33"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+#RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="rspec-mocks.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
+HOMEPAGE="https://github.com/rspec/rspec-mocks"
+SRC_URI="https://github.com/rspec/${PN}/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+LICENSE="MIT"
+SLOT="$(ver_cut 1)"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="test"
+
+SUBVERSION="$(ver_cut 1-2)"
+
+ruby_add_rdepend "=dev-ruby/rspec-support-${SUBVERSION}*
+ >=dev-ruby/diff-lcs-1.2.0 =dev-ruby/diff-lcs-1*"
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/rspec-core-3.12.0:3
+ >=dev-ruby/rspec-expectations-2.99.0:3
+ )"
+
+all_ruby_prepare() {
+ # Don't set up bundler: it doesn't understand our setup.
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+
+ # Remove the Gemfile to avoid running through 'bundle exec'
+ rm Gemfile || die
+
+ # And consequently avoid specs using bundler. This also avoids a
+ # circular dependency on aruba.
+ rm -f spec/integration/rails_support_spec.rb spec/support/aruba.rb || die
+
+ # Remove .rspec options to avoid dependency on newer rspec when
+ # bootstrapping.
+ rm .rspec || die
+
+ sed -i -e '1irequire "spec_helper"' spec/rspec/mocks/any_instance_spec.rb || die
+
+ sed -i -e 's/git ls-files --/find */' ${RUBY_FAKEGEM_GEMSPEC} || die
+}