summaryrefslogtreecommitdiff
path: root/dev-ruby/rspec-mocks
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /dev-ruby/rspec-mocks
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'dev-ruby/rspec-mocks')
-rw-r--r--dev-ruby/rspec-mocks/Manifest1
-rw-r--r--dev-ruby/rspec-mocks/rspec-mocks-2.99.2-r1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-ruby/rspec-mocks/Manifest b/dev-ruby/rspec-mocks/Manifest
index 58c6827d042c..f7d242f5feb6 100644
--- a/dev-ruby/rspec-mocks/Manifest
+++ b/dev-ruby/rspec-mocks/Manifest
@@ -1,6 +1,7 @@
DIST rspec-mocks-2.99.2-git.tgz 101731 BLAKE2B 27ae180381d427b642c53c351e7b53602caba4252ddf5393949d940be8474110eb0697901afaaa878cd8d368f081c6644c0fcbce86d9d14b9f93f48c027ae808 SHA512 dd3b9394d56de8d3089db7777cda1e1a5bbdc46486876a99a8a83b602b84ba0320913d8e8dabe5e0367645eb01b943607b93e67d87cc26e380c8db6e048e4e0d
DIST rspec-mocks-3.10.2-git.tgz 196040 BLAKE2B 8e975dc8480d4709f650ff27c517104714156c551b8b9ec04681132bd92be80bdb11867730f462e7fb6b672430246a0a11404dec5638b5350b57d81a8eac2e57 SHA512 ab11fa77c5f9e3bec2003dc8825d9582dcbffa08a36818bd9cdbe2dfd357113de3712c818deafc165530f9e4d2683ec06e54d37c37aeb820ae3cd592f76cf2cb
DIST rspec-mocks-3.9.1-git.tgz 192772 BLAKE2B abcc8fc82648993e6a407a8c4ac4f5b146b821e1e842c1dd2b95824d8468aac0ea796438d77e376c897675f66bd2bc9024da8fa5ccaf60139ea296b388d542cd SHA512 f804783fca4cf2258e83f82515cd5881ceae0bdd3aedb452a1db901e01de5dbca1d2bdef0ac0828a4bd23a1de58d127a42150c8c204219bca39ea7072619098f
+EBUILD rspec-mocks-2.99.2-r1.ebuild 1623 BLAKE2B 69c1d153b480908d66ee2850a70352c02c3cdccbb8a69229c233b6ef4029135e91b70c96eff88063295a3c328a08f38b133cc3ac1d22e401c1a79df60dad85d8 SHA512 0df31a0cec3d2fb790e486f9c93290d2625812877e6550f24b403e5444ba50ef6e1e7948b93c81c9eddb2909107d678b426281421923997b3943765c3b27c62a
EBUILD rspec-mocks-2.99.2.ebuild 1517 BLAKE2B 239e43ae3232aa4a6e8924375186ae5379499aff4a13b773465b6204dc79f66202ec86f65b668356aa567576df38d65b5f914ce858f444f37e691ce729c93ed6 SHA512 62c49e43f65c7a36422b3b3e6ac1af4fcb8a4dfb337a5960b7a8397a996190826691bdecb351510d23371bce173db6334f15863fef9dbc5df226bf851d6beb39
EBUILD rspec-mocks-3.10.2.ebuild 1442 BLAKE2B fec61c4afdf328f06e2c2a9d7e0f3644836376b9925dbf27a55e959956f9c049343a56e95e3272cf9d062d86d2914998309d6cd51a6f6db1b86352d90cd5adc8 SHA512 11f1f35d5b2d59292a42ad277b3676c5c34bfaa72e22bf5705150eeff1d94fc3688e5f9daaf2b11e327767d481102f1a1890329562c0a6e78bbae0146e9ed3e7
EBUILD rspec-mocks-3.9.1.ebuild 1435 BLAKE2B 82814e4352a4fad72c57ff163fcfc10ef08ac94b3048b3b96fa5c5a42e0d2612a8328365b5aa8002e8ef97c3fdc85d592eb9faf6c2d90a3b0a4b0c7c2f11479c SHA512 a5b411e0173fa229e6e754335911807c10768311508d8a2f8c0decff12c422cc6185290c9d2a5b9e94c9b510c8e739ae7a6e6c5957bcf9d1becbf0c56beaa90c
diff --git a/dev-ruby/rspec-mocks/rspec-mocks-2.99.2-r1.ebuild b/dev-ruby/rspec-mocks/rspec-mocks-2.99.2-r1.ebuild
new file mode 100644
index 000000000000..0a09d4cde658
--- /dev/null
+++ b/dev-ruby/rspec-mocks/rspec-mocks-2.99.2-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec"
+
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
+
+RUBY_FAKEGEM_GEMSPEC="rspec-mocks.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
+HOMEPAGE="http://rspec.rubyforge.org/"
+SRC_URI="https://github.com/rspec/${PN}/archive/v${PV}.tar.gz -> ${P}-git.tgz"
+
+LICENSE="MIT"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+ruby_add_bdepend "
+ test? (
+ >=dev-ruby/rspec-core-2.10.0:2
+ >=dev-ruby/rspec-expectations-2.99.0:2
+ )"
+
+all_ruby_prepare() {
+ # Don't set up bundler: it doesn't understand our setup.
+ sed -i -e '/[Bb]undler/d' Rakefile || die
+
+ # Remove the Gemfile to avoid running through 'bundle exec'
+ rm Gemfile || die
+
+ # Remove .rspec options to avoid dependency on newer rspec when
+ # bootstrapping.
+ rm .rspec || die
+
+ # Avoid a weird, and failing, test testing already installed code.
+ sed -e '/has an up-to-date caller_filter file/,/end/ s:^:#:' -i spec/rspec/mocks_spec.rb || die
+
+ # Psych and Syck are not supported by default anymore on ruby22.
+ rm spec/rspec/mocks/serialization_spec.rb || die
+
+ sed -i -e '/does not affect the ability to access the top-level constant/,/end/ s:^:#:' spec/rspec/mocks/mutate_const_spec.rb || die
+
+ sed -i -e 's/git ls-files --/find/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}