summaryrefslogtreecommitdiff
path: root/dev-ruby/rspec-json_expectations
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /dev-ruby/rspec-json_expectations
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'dev-ruby/rspec-json_expectations')
-rw-r--r--dev-ruby/rspec-json_expectations/Manifest2
-rw-r--r--dev-ruby/rspec-json_expectations/rspec-json_expectations-2.2.0.ebuild27
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/rspec-json_expectations/Manifest b/dev-ruby/rspec-json_expectations/Manifest
index 17297e84a5b1..1505efd68c60 100644
--- a/dev-ruby/rspec-json_expectations/Manifest
+++ b/dev-ruby/rspec-json_expectations/Manifest
@@ -1,3 +1,5 @@
DIST rspec-json_expectations-2.1.0.gem 14848 BLAKE2B 2c359351ba457297f7d561059183a8e32fa5762dbdc97c8ddb2432acb00c092fcc14a45e8f7625812420b926c4f177afdf4ff124f9b35d15b60fb58861c1f46a SHA512 1b09b959d6ecbc76c13b37fbf89cba381feb00505ce3a5701ad87ef1ed2ee178ea760508af809ac7dc8285c24d86dd7e33a7fb903a7f74472ca59d59f8df0daf
+DIST rspec-json_expectations-2.2.0.gem 14848 BLAKE2B c2f77e908eb0f473a5bae0ed49e133ebe71d4c471e2b32a9620f84e3881ca6aa92d188b8aafae8d92ee9111edcf2cc3636598c59e9f92747422f3c43c7e14563 SHA512 90da15c4c02404ac518955d65612fc7db28e8f91a756e5a25d0e5667026113f7a1be69cdc9bc656eeb89ccc7cb41069dd241401a2680f69528fb77d5491f2a83
EBUILD rspec-json_expectations-2.1.0.ebuild 687 BLAKE2B 7e61ceb76148fedfe598952ec6eb92672e4cf345c5213f154dcbbdf1193d29bb02e875ceea8deb4cbf5c2cfc2f70a049f368d5b5aef3a7b7c5984eb5103c80c2 SHA512 6889754bfbf1c52657782e7f17cceef88f55e677b6417c4a2c66c16a1cce685ef7e7754bd647e1197a19b34a44c0532735aea5a681469641b218f2d9d6234db7
+EBUILD rspec-json_expectations-2.2.0.ebuild 569 BLAKE2B 9e7254341f1db62ccd61ef68ae5263d1d73f7258f734958c5298cc7e3bba9f3c8d2f5b11ed5a8336ce32062d662a5feffb2c936f8893e3f46d73b572f4cb4b42 SHA512 315176d40c68ad32813dff4ccbc6da7816cb3a72c514adcea0e01f538170977ceb4d0f831187a344da6df034d12c64bd08bb726615fa6e413e84e7ba2c484588
MISC metadata.xml 359 BLAKE2B 7c62397e3d1ccb0bc72c162d533f024c1ed8ef77af4ed2460350a05731db31b66fad74356d8d025c3a2e8f7206a2f18d506e1d6af3ffbbadca8ae973deaa291d SHA512 70d5b53c0b741113a09ae01b215e3e9397db63e484010a57c681a5cbd121589daf140eeaf691392cb046c1b3a001046c07c8caaf37de6855f5c437b479a02a6b
diff --git a/dev-ruby/rspec-json_expectations/rspec-json_expectations-2.2.0.ebuild b/dev-ruby/rspec-json_expectations/rspec-json_expectations-2.2.0.ebuild
new file mode 100644
index 000000000000..b95f3edd5c66
--- /dev/null
+++ b/dev-ruby/rspec-json_expectations/rspec-json_expectations-2.2.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Set of matchers and helpers to allow you test your APIs responses."
+HOMEPAGE="https://github.com/waterlink/rspec-json_expectations"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-util/cucumber )"
+
+each_ruby_test() {
+ ${RUBY} -S cucumber --format progress features || die
+}