summaryrefslogtreecommitdiff
path: root/dev-ruby/rspec-json_expectations
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-ruby/rspec-json_expectations
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-ruby/rspec-json_expectations')
-rw-r--r--dev-ruby/rspec-json_expectations/Manifest3
-rw-r--r--dev-ruby/rspec-json_expectations/metadata.xml11
-rw-r--r--dev-ruby/rspec-json_expectations/rspec-json_expectations-2.1.0.ebuild31
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-ruby/rspec-json_expectations/Manifest b/dev-ruby/rspec-json_expectations/Manifest
new file mode 100644
index 000000000000..da18f94d2168
--- /dev/null
+++ b/dev-ruby/rspec-json_expectations/Manifest
@@ -0,0 +1,3 @@
+DIST rspec-json_expectations-2.1.0.gem 14848 SHA256 76593bd2025d076df534e18ff7b08e2cb117fb57637c2ecef3fc97b4e6866d50 SHA512 1b09b959d6ecbc76c13b37fbf89cba381feb00505ce3a5701ad87ef1ed2ee178ea760508af809ac7dc8285c24d86dd7e33a7fb903a7f74472ca59d59f8df0daf WHIRLPOOL 8498611f5c9ad2af2181d0051702be36cc45e774cad6d93d8676a37c553451c4aa48cd1a8a62c4d41e3f01df4b68cdd054e4d74ce6f08b858a260de9aef3fce8
+EBUILD rspec-json_expectations-2.1.0.ebuild 682 SHA256 01f1b7d0361b3395e5ab231006a400a9d6025bb1da87de85fb935ccf233838f5 SHA512 3dcd888f101f15ecdabaea41565fd7da91b4307a6d8da5b1ed223fcac9e64280fd976401c74f102ec9f02b93eb73a6826bac4280504d203ff2321ba8843db715 WHIRLPOOL a124afff3dcde6f9d768b9979a8ecb8a56111f205e2d9d26883963e5e96ebf8151e9c720f7e34795860bb854c381bd53b58971843773b24a2c0ec6b7cb8105d3
+MISC metadata.xml 359 SHA256 6567950cdcfca0060b280b22750222c0cd8e1d3d183371c8360805872418163e SHA512 70d5b53c0b741113a09ae01b215e3e9397db63e484010a57c681a5cbd121589daf140eeaf691392cb046c1b3a001046c07c8caaf37de6855f5c437b479a02a6b WHIRLPOOL 6c57a42ecfbc9db24b1775986dc7aa47911078892410b47ebecaf981986aa31de424a4088788c689fa7c5d1bb34f4fe7b9789965d109c774982771cee16f6ec5
diff --git a/dev-ruby/rspec-json_expectations/metadata.xml b/dev-ruby/rspec-json_expectations/metadata.xml
new file mode 100644
index 000000000000..3d3fa1d37b90
--- /dev/null
+++ b/dev-ruby/rspec-json_expectations/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">waterlink/rspec-json_expectations</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/rspec-json_expectations/rspec-json_expectations-2.1.0.ebuild b/dev-ruby/rspec-json_expectations/rspec-json_expectations-2.1.0.ebuild
new file mode 100644
index 000000000000..b6095cb98eef
--- /dev/null
+++ b/dev-ruby/rspec-json_expectations/rspec-json_expectations-2.1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby22 ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Set of matchers and helpers to allow you test your APIs responses."
+HOMEPAGE="https://github.com/waterlink/rspec-json_expectations"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="~amd64"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-util/cucumber )"
+
+all_ruby_prepare() {
+ sed -i -e '1irequire "forwardable"' lib/rspec/json_expectations/matchers.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -S cucumber --format progress features || die
+}