summaryrefslogtreecommitdiff
path: root/dev-ruby/rspec-json_expectations
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-ruby/rspec-json_expectations
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-ruby/rspec-json_expectations')
-rw-r--r--dev-ruby/rspec-json_expectations/Manifest1
-rw-r--r--dev-ruby/rspec-json_expectations/rspec-json_expectations-2.2.0-r1.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-ruby/rspec-json_expectations/Manifest b/dev-ruby/rspec-json_expectations/Manifest
index 4d4c86903d8d..ea405e6de31d 100644
--- a/dev-ruby/rspec-json_expectations/Manifest
+++ b/dev-ruby/rspec-json_expectations/Manifest
@@ -1,3 +1,4 @@
DIST rspec-json_expectations-2.2.0.gem 14848 BLAKE2B c2f77e908eb0f473a5bae0ed49e133ebe71d4c471e2b32a9620f84e3881ca6aa92d188b8aafae8d92ee9111edcf2cc3636598c59e9f92747422f3c43c7e14563 SHA512 90da15c4c02404ac518955d65612fc7db28e8f91a756e5a25d0e5667026113f7a1be69cdc9bc656eeb89ccc7cb41069dd241401a2680f69528fb77d5491f2a83
+EBUILD rspec-json_expectations-2.2.0-r1.ebuild 558 BLAKE2B f7a36e43df90e53d9f554fa69b5cfb9d771bf1041d5b7a4c3473b632d5572e81a48f3aa37bb4856bda32093bd5e08f61662f8b4f8c0fef12b2f82c738c67a852 SHA512 3ec16bfd37ef074f6fbdf83c0ec4f6dc221bbbe076ceac7773446b679d5516fb1ba63992364be2285c9cfd5d6dc90a823424ed55356c2e0ab0aa115b089c16af
EBUILD rspec-json_expectations-2.2.0.ebuild 596 BLAKE2B 0f6120caf03cd9aefa0533f51537b7307526d452d16b9649fe7c4aee8412adf37db47e9d33eb1f3129bd37e88af01497c5cb16f3520e4a99fe104d380e3e889b SHA512 e9e17f91999a434744a7e9bf5971d2fab915da47cd5e6a2eda4afdf90367a39b281c3123e5a5c05f3f33ae119410696e290534e45ee49d381cd3c2dad1dd0ad7
MISC metadata.xml 360 BLAKE2B 6c326af43c46464fe6a9bf5e5511ddbc3feabee9e53f829d4d689fb3b9984197c6827930cef434300fdb60f48eedf2273419b33ae888f048e2451937529ed57e SHA512 5d84579fcc4d87aa6f52d2f64ec075006608c783a6c074cc21539d14f4a15abb55b1dd3619a7e0639dcdc63a723e89d1b3868da0ab849529eb9ae92b14ea4a46
diff --git a/dev-ruby/rspec-json_expectations/rspec-json_expectations-2.2.0-r1.ebuild b/dev-ruby/rspec-json_expectations/rspec-json_expectations-2.2.0-r1.ebuild
new file mode 100644
index 000000000000..fd64c1dfd5aa
--- /dev/null
+++ b/dev-ruby/rspec-json_expectations/rspec-json_expectations-2.2.0-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27 ruby30"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+RUBY_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Set of matchers and helpers to allow you test your APIs responses"
+HOMEPAGE="https://github.com/waterlink/rspec-json_expectations"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_bdepend "test? ( dev-ruby/rspec dev-util/cucumber )"
+
+each_ruby_test() {
+ ${RUBY} -S cucumber --format progress features || die
+}