summaryrefslogtreecommitdiff
path: root/dev-ruby/rspec-expectations/rspec-expectations-3.11.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-26 21:58:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-26 21:58:12 +0100
commitd76b6613e545057331e9273ddd21e68d28d9e402 (patch)
tree2823b704acff0caa2bf185b4e4b38c95731cba39 /dev-ruby/rspec-expectations/rspec-expectations-3.11.1.ebuild
parentf6fd15e0418aea97c7ee77672468561cdac302e5 (diff)
gentoo auto-resync : 26:08:2023 - 21:58:11
Diffstat (limited to 'dev-ruby/rspec-expectations/rspec-expectations-3.11.1.ebuild')
-rw-r--r--dev-ruby/rspec-expectations/rspec-expectations-3.11.1.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/dev-ruby/rspec-expectations/rspec-expectations-3.11.1.ebuild b/dev-ruby/rspec-expectations/rspec-expectations-3.11.1.ebuild
deleted file mode 100644
index ac8cf76b410e..000000000000
--- a/dev-ruby/rspec-expectations/rspec-expectations-3.11.1.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-USE_RUBY="ruby27 ruby30 ruby31"
-
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-RUBY_FAKEGEM_RECIPE_DOC="none"
-RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
-
-RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
-HOMEPAGE="https://github.com/rspec/rspec-expectations"
-SRC_URI="https://github.com/rspec/${PN}/archive/v${PV}.tar.gz -> ${P}-git.tgz"
-
-LICENSE="MIT"
-SLOT="3"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~loong ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
-IUSE=""
-
-SUBVERSION="$(ver_cut 1-2)"
-
-ruby_add_rdepend ">=dev-ruby/diff-lcs-1.2.0 =dev-ruby/diff-lcs-1*
- =dev-ruby/rspec-support-${SUBVERSION}*"
-
-ruby_add_bdepend "test? (
- >=dev-ruby/rspec-mocks-3.2.0:3
- >=dev-ruby/rspec-support-3.5.0:3
- )"
-
-all_ruby_prepare() {
- # Don't set up bundler: it doesn't understand our setup.
- sed -i -e '/[Bb]undler/d' Rakefile || die
-
- # Remove the Gemfile to avoid running through 'bundle exec'
- rm -f Gemfile || die
-
- # fix up the gemspecs
- sed -i \
- -e '/git ls/d' \
- -e '/add_development_dependency/d' \
- "${RUBY_FAKEGEM_GEMSPEC}" || die
-}