summaryrefslogtreecommitdiff
path: root/dev-ruby/rspec-collection_matchers
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-ruby/rspec-collection_matchers
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-ruby/rspec-collection_matchers')
-rw-r--r--dev-ruby/rspec-collection_matchers/Manifest3
-rw-r--r--dev-ruby/rspec-collection_matchers/metadata.xml11
-rw-r--r--dev-ruby/rspec-collection_matchers/rspec-collection_matchers-1.1.3-r1.ebuild24
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-ruby/rspec-collection_matchers/Manifest b/dev-ruby/rspec-collection_matchers/Manifest
new file mode 100644
index 000000000000..68293d317c05
--- /dev/null
+++ b/dev-ruby/rspec-collection_matchers/Manifest
@@ -0,0 +1,3 @@
+DIST rspec-collection_matchers-1.1.3.gem 16896 BLAKE2B 76f020d986f7098b873c8d3c2d087a2399f863d6a2ebbc70c2b6cf38a120bd956b85e0c60ad736539972a3f5ad26095ec1bcebf9b6dacf0d2e8979bb84356a5c SHA512 3af81c016f259f363c126ac829c8bd51b9c67d54c5c8b2def317b430b852c27eabbd538b79f0a5a919d5edba66f9501c38de560a7ac26023fae7b5588b57439d
+EBUILD rspec-collection_matchers-1.1.3-r1.ebuild 584 BLAKE2B 957ddae72f4fcac29931d99c9100306a980b1c4bde812fcf7482f037a40a597f74076cb7c9078b6402c24df019410ef721ae6627cfeb8683b1cfbf632ce4de2e SHA512 6c1fce07c26849e18a227d95a5d84da4e304a57eadfd525bc81d33506c8246f75c951c47db9ed094a3bd7d518d393356017bfa9df2adcc7ba7cc2a42e2a81b19
+MISC metadata.xml 357 BLAKE2B 1c9db582a7501475800f309d82f162a893ba12f4156a137e4a2b0143448808d066a614d3bad0f23ba8525c658e624b2e105eaf2617114fe03205ecd567aaaac4 SHA512 410f3c228f598963f872d5701edc301479eefdafc8a58b00c0d287bb6c9ba542dbed4d7a31c569500225d1e47150b431d6de6b26b02c7e9d7a8882e3d475be0e
diff --git a/dev-ruby/rspec-collection_matchers/metadata.xml b/dev-ruby/rspec-collection_matchers/metadata.xml
new file mode 100644
index 000000000000..b034e2128499
--- /dev/null
+++ b/dev-ruby/rspec-collection_matchers/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">rspec/rspec-collection_matchers</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/rspec-collection_matchers/rspec-collection_matchers-1.1.3-r1.ebuild b/dev-ruby/rspec-collection_matchers/rspec-collection_matchers-1.1.3-r1.ebuild
new file mode 100644
index 000000000000..2652af0a7112
--- /dev/null
+++ b/dev-ruby/rspec-collection_matchers/rspec-collection_matchers-1.1.3-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+USE_RUBY="ruby23 ruby24 ruby25"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+
+RUBY_FAKEGEM_EXTRADOC="Changelog.md README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="A Behaviour Driven Development (BDD) framework for Ruby"
+HOMEPAGE="https://github.com/rspec/rspec-collection_matchers"
+
+LICENSE="MIT"
+SLOT="1"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/rspec-expectations-3.0.0"
+
+ruby_add_bdepend "test? ( >=dev-ruby/activemodel-3.0 )"